Grav: Stored XSS via Markdown audio/video media URL
CVE-2026-75831GHSA-6qw9-4vv5-jr97
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 2.0.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- <= 2.0.14
- Fixed in
- 2.0.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6qw9-4vv5-jr97 lists affected ranges: Packagist getgrav/grav >=0 <2.0.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6qw9-4vv5-jr97 lists affected ranges: Packagist getgrav/grav >=0 <=2.0.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-75831: 0.35% estimated exploitation activity in the next 30 days; percentile 28.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Target: github.com/getgrav/grav Affected resource: Grav\Common\Media\Traits\AudioMediaTrait / VideoMediaTrait sourceParsedownElement() — verified on 2.0.13 (latest stable) and develop HEAD 5a7070f Severity: Medium (~6.9 CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N — anchored to the sibling script-XSS advisory CVE-2026-42841, same PR:H / S:C / C:H / I:L) Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation) Summary A Markdown audio or video embed renders its <source element as raw HTML with the media URL concatenated unescaped. The URL fragment is reflected without any encoding, so ) breaks out of <source src="…" and injects arbitrary HTML — including a script-executing <svg onload — into the rendered page. Any user who views the page runs the attacker's JavaScript in their session; a logged-in administrator who views it exposes their same-origin Grav Admin session to the attacker's script. This is the next sink in the media-parameter injection class the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6qw9-4vv5-jr97
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6qw9-4vv5-jr97
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-75831 Advisory: Grav: Stored XSS via Markdown audio/video media URL IDs: CVE-2026-75831, GHSA-6qw9-4vv5-jr97 Record: https://patchnext.com/advisories/cve-2026-75831 (revision 3, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 2.0.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected <= 2.0.14; fixed in 2.0.15 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6qw9-4vv5-jr97 (OSV record GHSA-6qw9-4vv5-jr97 lists affected ranges: Packagist getgrav/grav >=0 <2.0.15 (fixed)) - Verified: https://github.com/advisories/GHSA-6qw9-4vv5-jr97 (GitHub-reviewed advisory GHSA-6qw9-4vv5-jr97 lists affected ranges: Packagist getgrav/grav >=0 <=2.0.14) Commands are suggestions: review each one before running it.
Loading voting…