Next.js: Unauthenticated Remote Code Execution on windows-hosted servers
CVE-2026-75604GHSA-p293-qw3h-jr36
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.3.3, 15.5.24), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 13.4.0, < 15.5.24>= 16.0.0, < 16.3.3
- Fixed in
- 16.3.3, 15.5.24
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p293-qw3h-jr36 lists affected ranges: npm next >=13.4.0 =16.0.0 <16.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p293-qw3h-jr36 lists affected ranges: npm next >=13.4.0 =16.0.0 <16.3.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-75604: 2.10% estimated exploitation activity in the next 30 days; percentile 81.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability in applications using Pages and App router without Cache Component can lead to remote code execution when the server is hosted on machines using a Windows filesystem. Workaround There is no known workaround for affected windows-hosted applications. You should upgrade immediately if your server is hosted on Windows.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p293-qw3h-jr36
- Revision 2 · amended ·
Amended from osv record GHSA-p293-qw3h-jr36
- Revision 1 · created ·
Published from ghsa record GHSA-p293-qw3h-jr36
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-75604 Advisory: Next.js: Unauthenticated Remote Code Execution on windows-hosted servers IDs: CVE-2026-75604, GHSA-p293-qw3h-jr36 Record: https://patchnext.com/advisories/cve-2026-75604 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 16.3.3, 15.5.24. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 13.4.0, < 15.5.24; >= 16.0.0, < 16.3.3; fixed in 16.3.3, 15.5.24 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p293-qw3h-jr36 (GitHub-reviewed advisory GHSA-p293-qw3h-jr36 lists affected ranges: npm next >=13.4.0 =16.0.0 <16.3.3) - Verified: https://osv.dev/vulnerability/GHSA-p293-qw3h-jr36 (OSV record GHSA-p293-qw3h-jr36 lists affected ranges: npm next >=13.4.0 =16.0.0 <16.3.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…