Skip to content

← Actionable
Critical, CVSS 9.1amended

Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext

CVE-2026-75595GHSA-c4c3-7fpv-j4q5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-handler 4.2.17.Final, 4.1.137.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.netty:netty-handler

    Affected
    >= 4.2.0.Final, <= 4.2.16.Final<= 4.1.136.Final
    Fixed in
    4.2.17.Final, 4.1.137.Final

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-75595: 0.32% estimated exploitation activity in the next 30 days; percentile 24.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A fragmented TLS ClientHello whose handshake header spans multiple records makes Netty silently fall back to the default SslContext; where per-SNI selection is the sole mTLS gate, an unauthenticated attacker can bypass the route's mTLS requirement. Details In io.netty.handler.ssl.SslClientHelloHandler#decode the guard that should wait for the 4-byte handshake header checks the wrong offset - it ignores the 5-byte record header that precedes it - and therefore never fires: When the first record's payload is < 4 bytes, handshakeLength = in.getUnsignedMedium(readerIndex + SslUtils.SSLRECORDHEADERLENGTH + 1); leads to IndexOutOfBoundsException . That is caught by the generic catch (Exception) block, which calls select(ctx, null) - this is the default SslContext. Fallback to default on parse failure is a problem when per-SNI selection is the sole mTLS gate. Impact SNI routing bypass. Escalates to an unauthenticated mTLS bypass only when: - mTLS is enforced solely via per-SNI…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c4c3-7fpv-j4q5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c4c3-7fpv-j4q5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-75595

Advisory: Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext
IDs: CVE-2026-75595, GHSA-c4c3-7fpv-j4q5
Record: https://patchnext.com/advisories/cve-2026-75595 (revision 3, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-handler 4.2.17.Final, 4.1.137.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-handler: affected >= 4.2.0.Final, <= 4.2.16.Final; <= 4.1.136.Final; fixed in 4.2.17.Final, 4.1.137.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-handler: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-handler.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c4c3-7fpv-j4q5 (OSV record GHSA-c4c3-7fpv-j4q5 lists affected ranges: Maven io.netty:netty-handler >=4.2.0.Final =0 <4.1.137.Final (fixed))
- Verified: https://github.com/advisories/GHSA-c4c3-7fpv-j4q5 (GitHub-reviewed advisory GHSA-c4c3-7fpv-j4q5 lists affected ranges: Maven io.netty:netty-handler >=4.2.0.Final =0 <=4.1.136.Final)

Commands are suggestions: review each one before running it.

Loading voting…