Kirby: Access to image files and limited access to JSON files outside of the site root via path traversal in the media handling
CVE-2026-75594GHSA-9vx2-j98c-p72w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 5.5.2, 4.9.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getkirby/cms
- Affected
- <= 4.9.4>= 5.0.0, < 5.5.2
- Fixed in
- 4.9.5, 5.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9vx2-j98c-p72w lists affected ranges: Packagist getkirby/cms >=0 =5.0.0 <5.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9vx2-j98c-p72w lists affected ranges: Packagist getkirby/cms >=0 =5.0.0 <5.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-75594: 0.76% estimated exploitation activity in the next 30 days; percentile 55.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TL;DR This vulnerability affects all Kirby sites that are deployed to a server that allows requests for URLs with encoded slashes (%2f), such as nginx, PHP's built-in server or Apache setups that have the option AllowEncodedSlashes enabled. It was possible to create and access thumbnails from media files in arbitrary accessible directories on the server that have a valid thumbnail configuration (JSON job file). It was also possible to detect the presence of files with the .json file extension anywhere on the server. This vulnerability is of high severity for affected sites. Server setups using Apache's default configuration or other servers that have been hardened against encoded slashes in URLs are not affected. ---- Introduction A path traversal (also known as directory traversal) vulnerability occurs when untrusted input is used to build a filesystem path without properly confining the result to an intended base directory. By injecting sequences such as ../, an attacker can escape…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9vx2-j98c-p72w
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9vx2-j98c-p72w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-75594 Advisory: Kirby: Access to image files and limited access to JSON files outside of the site root via path traversal in the media handling IDs: CVE-2026-75594, GHSA-9vx2-j98c-p72w Record: https://patchnext.com/advisories/cve-2026-75594 (revision 3, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 5.5.2, 4.9.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getkirby/cms: affected <= 4.9.4; >= 5.0.0, < 5.5.2; fixed in 4.9.5, 5.5.2 ## Suggested inspection (read-only) - Packagist getkirby/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getkirby/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9vx2-j98c-p72w (OSV record GHSA-9vx2-j98c-p72w lists affected ranges: Packagist getkirby/cms >=0 =5.0.0 <5.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-9vx2-j98c-p72w (GitHub-reviewed advisory GHSA-9vx2-j98c-p72w lists affected ranges: Packagist getkirby/cms >=0 =5.0.0 <5.5.2) Commands are suggestions: review each one before running it.
Loading voting…