GraphQL-core: Denial of service via comment tokens bypassing the parser's max_tokens limit
CVE-2026-75508GHSA-r77w-qph3-7vf8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphql-core 3.3.0rc1, 3.2.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI graphql-core
- Affected
- >= 3.2.3, < 3.2.12>= 3.3.0a3, < 3.3.0rc1
- Fixed in
- 3.2.12, 3.3.0rc1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r77w-qph3-7vf8 lists affected ranges: PyPI graphql-core >=3.2.3 =3.3.0a3 <3.3.0rc1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r77w-qph3-7vf8 lists affected ranges: PyPI graphql-core >=3.2.3 =3.3.0a3 <3.3.0rc1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-75508: 0.57% estimated exploitation activity in the next 30 days; percentile 47.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The parser's maxtokens limit — the documented defence against oversized GraphQL documents — did not count comment tokens. A document padded with comments could therefore pass a maxtokens check of any size while still allocating one Token object per comment, all of which stay reachable for the lifetime of the parsed document. A 38 MB comment-padded payload allocated roughly 92 MB of additional resident memory with maxtokens=5 in force. Details Lexer.lookahead() reads tokens one at a time and skips over comments, returning only the first non-comment token. Each skipped comment is nevertheless fully tokenized, allocated as a Token object, and linked into the persistent token list via token.next / token.prev — the chain that powers source-location reporting, and which is retained as long as the document is. Parser.advancelexer() incremented the token counter only for the tokens the lexer actually returned. Comments were therefore invisible to the accounting, and maxtokens bounded…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r77w-qph3-7vf8
- Revision 2 · amended ·
Amended from osv record GHSA-r77w-qph3-7vf8
- Revision 1 · created ·
Published from ghsa record GHSA-r77w-qph3-7vf8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-75508 Advisory: GraphQL-core: Denial of service via comment tokens bypassing the parser's max_tokens limit IDs: CVE-2026-75508, GHSA-r77w-qph3-7vf8 Record: https://patchnext.com/advisories/cve-2026-75508 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: graphql-core 3.3.0rc1, 3.2.12. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI graphql-core: affected >= 3.2.3, < 3.2.12; >= 3.3.0a3, < 3.3.0rc1; fixed in 3.2.12, 3.3.0rc1 ## Suggested inspection (read-only) - `python -m pip show graphql-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on graphql-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r77w-qph3-7vf8 (GitHub-reviewed advisory GHSA-r77w-qph3-7vf8 lists affected ranges: PyPI graphql-core >=3.2.3 =3.3.0a3 <3.3.0rc1) - Verified: https://osv.dev/vulnerability/GHSA-r77w-qph3-7vf8 (OSV record GHSA-r77w-qph3-7vf8 lists affected ranges: PyPI graphql-core >=3.2.3 =3.3.0a3 <3.3.0rc1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…