Skip to content

← Actionable
High, CVSS 7.5amended

GraphQL-core: Denial of service via quadratic complexity in the OverlappingFieldsCanBeMerged validation rule

CVE-2026-75507GHSA-vj8h-fx38-h3vc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphql-core 3.3.0rc1, 3.2.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI graphql-core

    Affected
    >= 3.0.0, < 3.2.12>= 3.3.0a1, < 3.3.0rc1
    Fixed in
    3.2.12, 3.3.0rc1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-75507: 0.60% estimated exploitation activity in the next 30 days; percentile 48.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OverlappingFieldsCanBeMerged validation rule can be driven into quadratic — and in the worst case O(n²·m²) — running time by a small, highly compressible query. A single 364 KB document can occupy one CPU core for over five minutes during validation, before any resolver runs. Because the rule is part of specifiedrules and therefore enabled by default, every GraphQL-core based server is affected at default settings. Details OverlappingFieldsCanBeMerged compares every pair of fields that share a response name and recurses into their sub-selections. The memoization added for CVE-2023-26144 (GHSA-9pv7-vfvm-6vr7) is keyed by named fragment identity, so it does not cover this path: inline fragments are flattened into the parent selection set before the cache is consulted, and therefore every pair is re-compared from scratch at every nesting level. Repeating an inline fragment that selects the same response name at two nesting levels multiplies the two effects. There was no…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vj8h-fx38-h3vc

  2. Revision 2 · amended ·

    Amended from osv record GHSA-vj8h-fx38-h3vc

  3. Revision 1 · created ·

    Published from ghsa record GHSA-vj8h-fx38-h3vc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-75507

Advisory: GraphQL-core: Denial of service via quadratic complexity in the OverlappingFieldsCanBeMerged validation rule
IDs: CVE-2026-75507, GHSA-vj8h-fx38-h3vc
Record: https://patchnext.com/advisories/cve-2026-75507 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: graphql-core 3.3.0rc1, 3.2.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI graphql-core: affected >= 3.0.0, < 3.2.12; >= 3.3.0a1, < 3.3.0rc1; fixed in 3.2.12, 3.3.0rc1

## Suggested inspection (read-only)
- `python -m pip show graphql-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on graphql-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vj8h-fx38-h3vc (GitHub-reviewed advisory GHSA-vj8h-fx38-h3vc lists affected ranges: PyPI graphql-core >=3.0.0 =3.3.0a1 <3.3.0rc1)
- Verified: https://osv.dev/vulnerability/GHSA-vj8h-fx38-h3vc (OSV record GHSA-vj8h-fx38-h3vc lists affected ranges: PyPI graphql-core >=3.0.0 =3.3.0a1 <3.3.0rc1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…