openssl-encrypt accepts refresh tokens as URL query parameters causing token leakage
CVE-2026-74880GHSA-4rh7-jwg9-m28m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl-encrypt 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI openssl-encrypt
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4rh7-jwg9-m28m lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4rh7-jwg9-m28m lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-74880: 0.56% estimated exploitation activity in the next 30 days; percentile 46.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Refresh tokens are accepted as URL query parameters in the keyserver and telemetry server routes. Affected Code Impact Tokens in URL query parameters are exposed in: - Server access logs - Proxy/CDN logs - Browser history - HTTP Referer headers - Network monitoring tools This creates significant token leakage risk. Recommended Fix - Accept refresh tokens in the request body (POST) instead of query parameters - Use Body(...) instead of Query(...) Fix Fixed in commit 4b2adb0 on branch releases/1.4.x — moved refresh token from Query parameter to POST body via RefreshRequest Pydantic model.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4rh7-jwg9-m28m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4rh7-jwg9-m28m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-74880 Advisory: openssl-encrypt accepts refresh tokens as URL query parameters causing token leakage IDs: CVE-2026-74880, GHSA-4rh7-jwg9-m28m Record: https://patchnext.com/advisories/cve-2026-74880 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openssl-encrypt 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI openssl-encrypt: affected < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - `python -m pip show openssl-encrypt`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openssl-encrypt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4rh7-jwg9-m28m (OSV record GHSA-4rh7-jwg9-m28m lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4rh7-jwg9-m28m (GitHub-reviewed advisory GHSA-4rh7-jwg9-m28m lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…