openssl-encrypt's readiness endpoint leaks database error details to unauthenticated callers
CVE-2026-74879GHSA-2vhw-q7vh-7xv2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl-encrypt 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI openssl-encrypt
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2vhw-q7vh-7xv2 lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2vhw-q7vh-7xv2 lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-74879: 0.44% estimated exploitation activity in the next 30 days; percentile 38.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The /ready endpoint in opensslencryptserver/server.py at lines 159-175 catches database errors and returns the full exception string in the response. Affected Code Impact Database exception messages can leak: - Database hostnames and IP addresses - Connection parameters and port numbers - Driver version information - Potentially database credentials if included in connection string errors This information is available to unauthenticated callers. Recommended Fix - Return a generic error message: {"status": "notready", "reason": "database unavailable"} - Log the full exception server-side for debugging Fix Fixed in commit 7aa8787 on branch releases/1.4.x — replaced str(e) with generic "database check failed" message; full exception logged server-side at WARNING level.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2vhw-q7vh-7xv2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2vhw-q7vh-7xv2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-74879 Advisory: openssl-encrypt's readiness endpoint leaks database error details to unauthenticated callers IDs: CVE-2026-74879, GHSA-2vhw-q7vh-7xv2 Record: https://patchnext.com/advisories/cve-2026-74879 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openssl-encrypt 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI openssl-encrypt: affected < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - `python -m pip show openssl-encrypt`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openssl-encrypt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2vhw-q7vh-7xv2 (OSV record GHSA-2vhw-q7vh-7xv2 lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-2vhw-q7vh-7xv2 (GitHub-reviewed advisory GHSA-2vhw-q7vh-7xv2 lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…