Skip to content

← Actionable
Medium, CVSS 6.6amended

openssl-encrypt's unverified key bundle from_dict() + to_identity() path allows encryption to attacker keys

CVE-2026-74876GHSA-8h88-gxp3-j7pg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl-encrypt 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-74876: 0.35% estimated exploitation activity in the next 30 days; percentile 28.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The PublicKeyBundle.fromdict() method in opensslencrypt/modules/keybundle.py at lines 329-361 creates bundles from untrusted data without verifying the signature. The docstring warns to call verifysignature() after creation, but the toidentity() method (line 363-391) can convert an unverified bundle directly to an Identity object. Affected Code Impact If fromdict() followed by toidentity() is called without an intervening verifysignature() call, encryption could be performed against an attacker's public key, leaking secrets. While keyresolver.py (lines 146-147) does verify before use, the unguarded API path remains directly callable. Recommended Fix - Add a verified flag to PublicKeyBundle that must be set before toidentity() can be called - Or have toidentity() automatically call verifysignature() and raise on failure - Or make fromdict() require verification as part of construction Fix Fixed in commit f4a1ba6 on branch releases/1.4.x — fromdict() now verifies selfsignature…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8h88-gxp3-j7pg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8h88-gxp3-j7pg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-74876

Advisory: openssl-encrypt's unverified key bundle from_dict() + to_identity() path allows encryption to attacker keys
IDs: CVE-2026-74876, GHSA-8h88-gxp3-j7pg
Record: https://patchnext.com/advisories/cve-2026-74876 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openssl-encrypt 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openssl-encrypt: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `python -m pip show openssl-encrypt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openssl-encrypt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8h88-gxp3-j7pg (OSV record GHSA-8h88-gxp3-j7pg lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8h88-gxp3-j7pg (GitHub-reviewed advisory GHSA-8h88-gxp3-j7pg lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…