Skip to content

← Actionable
Medium, CVSS 6.6amended

openssl-encrypt has non-cryptographic PRNG used for steganography pixel selection

CVE-2026-74874GHSA-vfgx-5q85-58q3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl-encrypt 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-74874: 0.44% estimated exploitation activity in the next 30 days; percentile 38.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The generatepseudorandomsequence() function in opensslencrypt/plugins/steganography/core/utils.py at lines 89-91 uses Python's random module (Mersenne Twister) for steganographic pixel/sample selection. Affected Code Additionally, the steganography password is stored as a plain Python string (not SecureBytes) and only 8 bytes (64 bits) of the SHA-256 hash are used for the seed, reducing effective security to 64 bits. Impact The Mersenne Twister's state can be recovered from approximately 624 outputs. An attacker who knows or guesses the password can predict the PRNG sequence and determine exactly which pixels contain hidden data, potentially extracting the hidden data without the password. Recommended Fix - Use HMAC-DRBG or secrets module for cryptographically secure pixel selection - Use full 32-byte SHA-256 output as seed material - Store the password in SecureBytes instead of a plain string Fix Fixed in commit 09e96e0 on branch releases/1.4.x — replaced…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vfgx-5q85-58q3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vfgx-5q85-58q3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-74874

Advisory: openssl-encrypt has non-cryptographic PRNG used for steganography pixel selection
IDs: CVE-2026-74874, GHSA-vfgx-5q85-58q3
Record: https://patchnext.com/advisories/cve-2026-74874 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openssl-encrypt 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openssl-encrypt: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `python -m pip show openssl-encrypt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openssl-encrypt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vfgx-5q85-58q3 (OSV record GHSA-vfgx-5q85-58q3 lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vfgx-5q85-58q3 (GitHub-reviewed advisory GHSA-vfgx-5q85-58q3 lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…