Skip to content

← Actionable
Medium, CVSS 6.6amended

openssl-encrypt has visible password in process list via --password CLI argument

CVE-2026-74873GHSA-h3m5-p59h-x88p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl-encrypt 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-74873: 0.32% estimated exploitation activity in the next 30 days; percentile 24.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Passwords passed via the --password / -p CLI argument in opensslencrypt/modules/cryptclisubparser.py at lines 150-154 are visible to any user on the system via ps aux or /proc/[pid]/cmdline. Affected Code Similarly, --keystore-password exposes the keystore password. Impact On multi-user systems, any user can observe the encryption password by listing processes. The CRYPTPASSWORD environment variable alternative is also visible via /proc/[pid]/environ (though with slightly restricted access). Recommended Fix - Document the security implications prominently - Recommend interactive prompting (already supported) as the secure default - Consider supporting password file descriptors (--password-fd) or reading from stdin - Consider marking the argument as deprecated in favor of interactive prompting Fix Fixed in commit e78a366 on branch releases/1.4.x — added --password-file and --password-fd arguments; added OPENSSLENCRYPTPASSWORD env var support; --password now emits deprecation…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-h3m5-p59h-x88p

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-h3m5-p59h-x88p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-74873

Advisory: openssl-encrypt has visible password in process list via --password CLI argument
IDs: CVE-2026-74873, GHSA-h3m5-p59h-x88p
Record: https://patchnext.com/advisories/cve-2026-74873 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openssl-encrypt 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openssl-encrypt: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `python -m pip show openssl-encrypt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openssl-encrypt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h3m5-p59h-x88p (OSV record GHSA-h3m5-p59h-x88p lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-h3m5-p59h-x88p (GitHub-reviewed advisory GHSA-h3m5-p59h-x88p lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…