Skip to content

← Actionable
Medium, CVSS 6.6amended

openssl-encrypt: Dynamic .so loading for Whirlpool uses broad glob pattern without integrity verification

CVE-2026-74872GHSA-j48q-4c78-rhf9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl-encrypt 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-74872: 0.68% estimated exploitation activity in the next 30 days; percentile 52.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Severity: HIGH Summary The Whirlpool hash implementation in opensslencrypt/modules/registry/hashregistry.py at lines 570-589 uses glob patterns to find .so modules in site-packages and loads the first match via importlib without verifying module integrity. Affected Code Impact The glob pattern "whirlpoolpy313.so" is broad and takes the first match without verifying: - File hash/signature - File ownership/permissions - Whether it's a legitimate module If an attacker can place a malicious .so file matching this pattern in any site-packages directory, it will be loaded and native code executed. Recommended Fix - Verify the module's integrity (hash or signature) before loading - Use a specific filename rather than a glob pattern - Check file permissions and ownership Fix Fixed in commit 963d0d1 on branch releases/1.4.x — added os.path.realpath() to resolve symlinks and validation that found .so files are within known site-packages directories before loading.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j48q-4c78-rhf9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-j48q-4c78-rhf9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-74872

Advisory: openssl-encrypt: Dynamic .so loading for Whirlpool uses broad glob pattern without integrity verification
IDs: CVE-2026-74872, GHSA-j48q-4c78-rhf9
Record: https://patchnext.com/advisories/cve-2026-74872 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openssl-encrypt 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openssl-encrypt: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `python -m pip show openssl-encrypt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openssl-encrypt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j48q-4c78-rhf9 (OSV record GHSA-j48q-4c78-rhf9 lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-j48q-4c78-rhf9 (GitHub-reviewed advisory GHSA-j48q-4c78-rhf9 lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…