Skip to content

← Actionable
Medium, CVSS 5.8amended

@fastify/busboy vulnerable to CRLF injection via multipart Content-Disposition filename and name

CVE-2026-74866GHSA-gxm5-99cw-xjw9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/busboy 3.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
EPSS
  • CVE-2026-74866: 0.33% estimated exploitation activity in the next 30 days; percentile 25.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact @fastify/busboy 3.2.1 and earlier retains a bare carriage return or line feed inside the parsed Content-Disposition parameters returned to the application. The multipart header parser ends a header line only on the two-byte \r\n sequence, so a lone CR or LF embedded in a part header is carried verbatim into the filename and field name delivered by the file and field events. An application that forwards the supplied filename or name into a CR/LF-sensitive sink cannot anticipate the embedded control character. An attacker who uploads a file whose filename or field name contains a bare CR or LF can pollute filenames on disk when the upload is saved under its original name, inject forged lines into logs, or inject headers on a downstream hop that does not re-validate CR/LF, such as object-storage metadata or a proxied backend. Applications using @fastify/busboy directly, or through @fastify/multipart and its consumers, are affected. Patches Upgrade to @fastify/busboy 3.2.2 or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gxm5-99cw-xjw9

  2. Revision 2 · amended ·

    Amended from osv record GHSA-gxm5-99cw-xjw9

  3. Revision 1 · created ·

    Published from ghsa record GHSA-gxm5-99cw-xjw9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-74866

Advisory: @fastify/busboy vulnerable to CRLF injection via multipart Content-Disposition filename and name
IDs: CVE-2026-74866, GHSA-gxm5-99cw-xjw9
Record: https://patchnext.com/advisories/cve-2026-74866 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastify/busboy 3.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastify/busboy: affected < 3.2.2; fixed in 3.2.2

## Suggested inspection (read-only)
- `npm ls @fastify/busboy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastify/busboy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gxm5-99cw-xjw9 (GitHub-reviewed advisory GHSA-gxm5-99cw-xjw9 lists affected ranges: npm @fastify/busboy >=0 <3.2.2)
- Verified: https://osv.dev/vulnerability/GHSA-gxm5-99cw-xjw9 (OSV record GHSA-gxm5-99cw-xjw9 lists affected ranges: npm @fastify/busboy >=0 <3.2.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…