HashiCorp Nomad vulnerable to a path traversal
CVE-2026-7474GHSA-hx53-77qj-8663
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/nomad 1.11.0-rc.1.0.20260511152149-cd7240c4099a), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.11.0-rc.1.0.20260511152149-cd7240c4099a
- Fixed in
- 1.11.0-rc.1.0.20260511152149-cd7240c4099a
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hx53-77qj-8663 lists affected ranges: Go github.com/hashicorp/nomad >=0 <1.11.0-rc.1.0.20260511152149-cd7240c4099a
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-7474: 8.16% estimated exploitation activity in the next 30 days; percentile 94.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
HashiCorp Nomad and Nomad Enterprise prior to 2.0.1 are vulnerable to code execution on the client host through a path traversal attack. This vulnerability (CVE-2026-7474) is fixed in Nomad 2.0.1, 1.11.5 and 1.10.11.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hx53-77qj-8663
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-7474 Advisory: HashiCorp Nomad vulnerable to a path traversal IDs: CVE-2026-7474, GHSA-hx53-77qj-8663 Record: https://patchnext.com/advisories/cve-2026-7474 (revision 1, source checked 26 Oct 2026, 15:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/nomad 1.11.0-rc.1.0.20260511152149-cd7240c4099a. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/nomad: affected < 1.11.0-rc.1.0.20260511152149-cd7240c4099a; fixed in 1.11.0-rc.1.0.20260511152149-cd7240c4099a ## Suggested inspection (read-only) - Go github.com/hashicorp/nomad: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/nomad. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hx53-77qj-8663 (GitHub-reviewed advisory GHSA-hx53-77qj-8663 lists affected ranges: Go github.com/hashicorp/nomad >=0 <1.11.0-rc.1.0.20260511152149-cd7240c4099a) Commands are suggestions: review each one before running it.
Loading voting…