Solspace Freeform: Limited Twig template injection via submitted field values
CVE-2026-73858GHSA-gxrg-x694-283w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (solspace/craft-freeform 5.10.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist solspace/craft-freeform
- Affected
- >= 5.0.0, <= 5.10.13
- Fixed in
- 5.10.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gxrg-x694-283w lists affected ranges: Packagist solspace/craft-freeform >=5.0.0 <5.10.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gxrg-x694-283w lists affected ranges: Packagist solspace/craft-freeform >=5.0.0 <=5.10.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-73858: 0.55% estimated exploitation activity in the next 30 days; percentile 45.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A limited server-side Twig template injection issue was identified in Solspace Freeform for Craft CMS. In affected versions, submitted form field values could be evaluated as Twig in certain rendering contexts. Unauthenticated users could submit Twig expressions through public Freeform forms and have those expressions evaluated when the submitted values were rendered back into the form response. Confirmed impact includes disclosure of limited server/environment information, such as the PHP version and absolute filesystem paths. No evidence was found that this issue allowed access to Craft globals, environment variables, database credentials, mailer credentials, security keys, or remote code execution in the tested environment. Details Plugin: Solspace Freeform Affected versions: Freeform 5.0.0 through 5.10.13 CMS: Craft CMS Authentication required: None Attack vector: Public Freeform form submission Submitted field values were passed through Freeform’s isolated Twig renderer.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gxrg-x694-283w
- Revision 1 · created ·
Published from osv record GHSA-gxrg-x694-283w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73858 Advisory: Solspace Freeform: Limited Twig template injection via submitted field values IDs: CVE-2026-73858, GHSA-gxrg-x694-283w Record: https://patchnext.com/advisories/cve-2026-73858 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: solspace/craft-freeform 5.10.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist solspace/craft-freeform: affected >= 5.0.0, <= 5.10.13; fixed in 5.10.14 ## Suggested inspection (read-only) - Packagist solspace/craft-freeform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on solspace/craft-freeform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gxrg-x694-283w (OSV record GHSA-gxrg-x694-283w lists affected ranges: Packagist solspace/craft-freeform >=5.0.0 <5.10.14 (fixed)) - Verified: https://github.com/advisories/GHSA-gxrg-x694-283w (GitHub-reviewed advisory GHSA-gxrg-x694-283w lists affected ranges: Packagist solspace/craft-freeform >=5.0.0 <=5.10.13) Commands are suggestions: review each one before running it.
Loading voting…