KubeVirt has a Link Following vulnerability
CVE-2026-7374GHSA-7jcp-v9w4-wjmg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kubevirt.io/kubevirt 1.8.3, 1.7.4, 1.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.8.0-alpha.0, < 1.8.3>= 1.7.0-alpha.0, < 1.7.4< 1.6.6
- Fixed in
- 1.6.6, 1.8.3, 1.7.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7jcp-v9w4-wjmg lists affected ranges: Go kubevirt.io/kubevirt >=1.8.0-alpha.0 =1.7.0-alpha.0 =0 <1.6.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-7374: 0.74% estimated exploitation activity in the next 30 days; percentile 54.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in KubeVirt's virt-handler component. This vulnerability allows an authenticated OpenShift user with edit permissions in a single namespace to exploit improper symlink validation when connecting to virtual machine console sockets. By replacing the console socket with a symlink to the host's container runtime (CRI-O) socket, an attacker can hijack virt-handler's privileged connection. This enables the attacker to access any Unix socket on the host, potentially leading to full control of the node and the entire cluster.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7jcp-v9w4-wjmg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-7374 Advisory: KubeVirt has a Link Following vulnerability IDs: CVE-2026-7374, GHSA-7jcp-v9w4-wjmg Record: https://patchnext.com/advisories/cve-2026-7374 (revision 1, source checked 26 Oct 2026, 15:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kubevirt.io/kubevirt 1.8.3, 1.7.4, 1.6.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go kubevirt.io/kubevirt: affected >= 1.8.0-alpha.0, < 1.8.3; >= 1.7.0-alpha.0, < 1.7.4; < 1.6.6; fixed in 1.6.6, 1.8.3, 1.7.4 ## Suggested inspection (read-only) - Go kubevirt.io/kubevirt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kubevirt.io/kubevirt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7jcp-v9w4-wjmg (GitHub-reviewed advisory GHSA-7jcp-v9w4-wjmg lists affected ranges: Go kubevirt.io/kubevirt >=1.8.0-alpha.0 =1.7.0-alpha.0 =0 <1.6.6) Commands are suggestions: review each one before running it.
Loading voting…