OpenChoreo: Authenticated OS command injection via OpenChoreo Workflow Plane templates enables code execution in privileged pods
CVE-2026-73667GHSA-2mw5-23gm-pccq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openchoreo/openchoreo 1.2.0-rc.2, 1.1.4, 1.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/openchoreo/openchoreo
- Affected
- < 1.0.4>= 1.1.0, < 1.1.4>= 1.2.0-rc.1, < 1.2.0-rc.2
- Fixed in
- 1.0.4, 1.1.4, 1.2.0-rc.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2mw5-23gm-pccq lists affected ranges: Go github.com/openchoreo/openchoreo >=0 =1.1.0 =1.2.0-rc.1 <1.2.0-rc.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6357 lists affected ranges: Go github.com/openchoreo/openchoreo >=0 =1.1.0 =1.2.0-rc.1 <1.2.0-rc.2 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2mw5-23gm-pccq lists affected ranges: Go github.com/openchoreo/openchoreo >=0 =1.1.0 =1.2.0-rc.1 <1.2.0-rc.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-73667: 0.86% estimated exploitation activity in the next 30 days; percentile 58.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary OpenChoreo Workflow Plane templates were vulnerable to OS command injection because some developer-controlled workflow parameters were interpolated directly into shell program text executed through sh -c. An authenticated user with permission to configure and trigger an affected workflow could supply crafted parameter values containing shell metacharacters. Because Argo substituted these values directly into the shell script before execution, the values could alter the script and execute arbitrary commands inside the workflow pod. In affected configurations, some build and publish templates used privileged Podman containers without Kubernetes pod user-namespace isolation. Consequently, injected commands could run as UID 0 inside a privileged container, with UID 0 mapped into the host user namespace. This substantially increased the potential impact of the command-injection vulnerability. The remediation ensures that workflow parameters are treated as data rather than…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2mw5-23gm-pccq
- Revision 2 · amended ·
Amended from osv record GO-2026-6357
- Revision 1 · created ·
Published from osv record GHSA-2mw5-23gm-pccq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73667 Advisory: OpenChoreo: Authenticated OS command injection via OpenChoreo Workflow Plane templates enables code execution in privileged pods IDs: CVE-2026-73667, GHSA-2mw5-23gm-pccq Record: https://patchnext.com/advisories/cve-2026-73667 (revision 3, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/openchoreo/openchoreo 1.2.0-rc.2, 1.1.4, 1.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/openchoreo/openchoreo: affected < 1.0.4; >= 1.1.0, < 1.1.4; >= 1.2.0-rc.1, < 1.2.0-rc.2; fixed in 1.0.4, 1.1.4, 1.2.0-rc.2 ## Suggested inspection (read-only) - Go github.com/openchoreo/openchoreo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/openchoreo/openchoreo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2mw5-23gm-pccq (OSV record GHSA-2mw5-23gm-pccq lists affected ranges: Go github.com/openchoreo/openchoreo >=0 =1.1.0 =1.2.0-rc.1 <1.2.0-rc.2 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6357 (OSV record GO-2026-6357 lists affected ranges: Go github.com/openchoreo/openchoreo >=0 =1.1.0 =1.2.0-rc.1 <1.2.0-rc.2 (fixed)) - Verified: https://github.com/advisories/GHSA-2mw5-23gm-pccq (GitHub-reviewed advisory GHSA-2mw5-23gm-pccq lists affected ranges: Go github.com/openchoreo/openchoreo >=0 =1.1.0 =1.2.0-rc.1 <1.2.0-rc.2) Commands are suggestions: review each one before running it.
Loading voting…