Skip to content

← Actionable
Medium, CVSS 5.7amended

TypeORM: migration:generate template-literal code injection

CVE-2026-73651GHSA-2rp8-mm9q-fp49

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typeorm 1.1.0, 0.3.31), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm typeorm

    Affected
    < 0.3.31>= 1.0.0, < 1.1.0
    Fixed in
    0.3.31, 1.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.7 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-73651: 0.39% estimated exploitation activity in the next 30 days; percentile 33.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary typeorm migration:generate embeds database schema metadata into JS/TS template literals, escaping backticks but not ${...}. An attacker who can write schema metadata (column comments, defaults, view definitions) achieves arbitrary code execution on the host that loads the generated migration. Details MigrationGenerateCommand.ts (L117-138) wraps each SQL statement in a JS template literal, escaping only backticks: Introspected schema strings reach this sink through driver query runners: | Driver | Metadata source | Source | |---|---|---| | Postgres | column DEFAULT, COMMENT, CHECK constraints, view definitions | PostgresQueryRunner.ts:1782, L1898, L2287, L4125 | | MySQL/MariaDB | COLUMNDEFAULT, COLUMNCOMMENT | MysqlQueryRunner.ts:2873-2974, L3580-3583 | | CockroachDB | Same patterns as Postgres | CockroachQueryRunner.ts | escapeComment() on each driver strips only null bytes, leaving ${...} intact: When the migration file is loaded (migration:run, import, or require), the JS…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2rp8-mm9q-fp49

  2. Revision 1 · created ·

    Published from osv record GHSA-2rp8-mm9q-fp49

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73651

Advisory: TypeORM: migration:generate template-literal code injection
IDs: CVE-2026-73651, GHSA-2rp8-mm9q-fp49
Record: https://patchnext.com/advisories/cve-2026-73651 (revision 2, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typeorm 1.1.0, 0.3.31. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm typeorm: affected < 0.3.31; >= 1.0.0, < 1.1.0; fixed in 0.3.31, 1.1.0

## Suggested inspection (read-only)
- `npm ls typeorm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typeorm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2rp8-mm9q-fp49 (OSV record GHSA-2rp8-mm9q-fp49 lists affected ranges: npm typeorm >=0 =1.0.0 <1.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2rp8-mm9q-fp49 (GitHub-reviewed advisory GHSA-2rp8-mm9q-fp49 lists affected ranges: npm typeorm >=0 =1.0.0 <1.1.0)

Commands are suggestions: review each one before running it.

Loading voting…