Rails HTML Sanitizers: Possible XSS vulnerability with certain configurations
CVE-2026-73648GHSA-cj75-f6xr-r4g7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rails-html-sanitizer 1.7.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rails-html-sanitizer
- Affected
- >= 1.0.3, < 1.7.1
- Fixed in
- 1.7.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cj75-f6xr-r4g7 lists affected ranges: RubyGems rails-html-sanitizer >=1.0.3 <1.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-73648: 0.55% estimated exploitation activity in the next 30 days; percentile 45.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There is a possible cross-site scripting vulnerability in rails-html-sanitizer when the sanitizer is configured to allow an SVG reference element such as <use. See related GHSA-9wjq-cp2p-hrgf in Loofah, whose SVG local-reference logic rails-html-sanitizer mirrors. - Versions affected: = 1.0.3, < 1.7.1 - Not affected: < 1.0.3 - Fixed versions: 1.7.1 Impact Rails::HTML::PermitScrubber restricts SVG reference elements in the SVGALLOWLOCALHREF collection to local, same-document references, but that restriction covered only the xlink:href attribute. Browsers also accept a plain href attribute per the SVG 2 spec, and it was not restricted, so those elements could reference arbitrary external documents. SVG <use can load and render external SVG content by reference, and if the referenced document is same-origin and contains scripts, it could execute in the context of the sanitized document. <feImage can load external images, which can be used for tracking. Applications are impacted…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cj75-f6xr-r4g7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73648 Advisory: Rails HTML Sanitizers: Possible XSS vulnerability with certain configurations IDs: CVE-2026-73648, GHSA-cj75-f6xr-r4g7 Record: https://patchnext.com/advisories/cve-2026-73648 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rails-html-sanitizer 1.7.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rails-html-sanitizer: affected >= 1.0.3, < 1.7.1; fixed in 1.7.1 ## Suggested inspection (read-only) - RubyGems rails-html-sanitizer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rails-html-sanitizer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cj75-f6xr-r4g7 (GitHub-reviewed advisory GHSA-cj75-f6xr-r4g7 lists affected ranges: RubyGems rails-html-sanitizer >=1.0.3 <1.7.1) Commands are suggestions: review each one before running it.
Loading voting…