Skip to content

← Actionable
Medium, CVSS 5.6amended

Quasar: Prototype pollution in the extend() utility

CVE-2026-73647GHSA-3r53-75j5-3g7j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (quasar 2.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm quasar

    Affected
    <= 2.21.4
    Fixed in
    2.22.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.6 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-73647: 0.39% estimated exploitation activity in the next 30 days; percentile 32.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary quasar@2.20.1, the latest published version at the time of testing, appears to be vulnerable to prototype pollution through the public extend() utility exported from the package root. When extend(true, target, source) is used for a deep merge, attacker-controlled object keys are recursively copied into the target object without blocking prototype-pollution primitives such as proto, constructor, or prototype. This can allow attacker-controlled properties to be written to Object.prototype. Details Affected source: Distributed files include: The package root publicly exports extend. During deep merge, source object keys are recursively assigned into the target object. If the source object contains an own proto property, the merge can descend into the prototype object and assign attacker-controlled properties onto Object.prototype. PoC Observed output: Expected output: Impact This is a prototype pollution vulnerability. If an application passes user-controlled or partially…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3r53-75j5-3g7j

  2. Revision 1 · created ·

    Published from osv record GHSA-3r53-75j5-3g7j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73647

Advisory: Quasar: Prototype pollution in the extend() utility
IDs: CVE-2026-73647, GHSA-3r53-75j5-3g7j
Record: https://patchnext.com/advisories/cve-2026-73647 (revision 2, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: quasar 2.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm quasar: affected <= 2.21.4; fixed in 2.22.0

## Suggested inspection (read-only)
- `npm ls quasar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on quasar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3r53-75j5-3g7j (OSV record GHSA-3r53-75j5-3g7j lists affected ranges: npm quasar >=0 <2.22.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3r53-75j5-3g7j (GitHub-reviewed advisory GHSA-3r53-75j5-3g7j lists affected ranges: npm quasar >=0 <=2.21.4)

Commands are suggestions: review each one before running it.

Loading voting…