OpenDJ SASL PLAIN authzid bypassing the proxy ACI scope check
CVE-2026-73644GHSA-p279-2cqp-84jg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openidentityplatform.opendj:opendj-server-legacy 5.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.openidentityplatform.opendj:opendj-server-legacy
- Affected
- <= 5.1.1
- Fixed in
- 5.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p279-2cqp-84jg lists affected ranges: Maven org.openidentityplatform.opendj:opendj-server-legacy >=0 <=5.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-73644: 0.41% estimated exploitation activity in the next 30 days; percentile 35.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When a SASL PLAIN bind supplies an authorization identity (authzid) that resolves to a different user, PlainSASLMechanismHandler verified only the PROXIEDAUTH privilege and never evaluated the "proxy" access-control right (the mayProxy ACI scope check). As a result, any account holding the proxied-auth privilege could assume any resolvable non-root identity without being granted a proxy ACI for that target. This diverges from every other proxy path in OpenDJ — the proxied-authorization controls (RFC 4370) and the DIGEST-MD5 / GSSAPI authzid handlers all require both the privilege and the mayProxy scope grant. Impact Privilege escalation / authorization bypass: a holder of proxied-auth can act as arbitrary directory users beyond the scope intended by the deployment's proxy ACIs, defeating the ACI-based restriction on which identities may be impersonated. Root/Directory Manager is not assumable this way. Fix Enforce the mayProxy scope check on the SASL PLAIN authzid path (both…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p279-2cqp-84jg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73644 Advisory: OpenDJ SASL PLAIN authzid bypassing the proxy ACI scope check IDs: CVE-2026-73644, GHSA-p279-2cqp-84jg Record: https://patchnext.com/advisories/cve-2026-73644 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.openidentityplatform.opendj:opendj-server-legacy 5.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.openidentityplatform.opendj:opendj-server-legacy: affected <= 5.1.1; fixed in 5.1.2 ## Suggested inspection (read-only) - Maven org.openidentityplatform.opendj:opendj-server-legacy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.openidentityplatform.opendj:opendj-server-legacy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p279-2cqp-84jg (GitHub-reviewed advisory GHSA-p279-2cqp-84jg lists affected ranges: Maven org.openidentityplatform.opendj:opendj-server-legacy >=0 <=5.1.1) Commands are suggestions: review each one before running it.
Loading voting…