GitPython: Unsafe git option guard bypass via single-character kwarg value token smuggling enables arbitrary command execution
CVE-2026-73625GHSA-r9mr-m37c-5fr3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitpython 3.1.54), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gitpython
- Affected
- <= 3.1.53
- Fixed in
- 3.1.54
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r9mr-m37c-5fr3 lists affected ranges: PyPI gitpython >=0 <3.1.54 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r9mr-m37c-5fr3 lists affected ranges: PyPI gitpython >=0 <=3.1.53
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2026-73625: 0.68% estimated exploitation activity in the next 30 days; percentile 52.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary GitPython's checkunsafeoptions guard (the control introduced by CVE-2026-42215 / GHSA-2f96 and hardened since) can be bypassed for every guarded method (clone/clonefrom, fetch/pull/push, lsremote, itercommits, blame, archive) by smuggling an option token inside the VALUE of a single-character kwarg. In the default allowunsafeoptions=False configuration this yields arbitrary command execution via --upload-pack. Root Cause The guard builds its candidate option list from kwarg KEYS only: optioncandidates([], {"n":"--upload-pack=<cmd"}) returns ['-n'] (cmd.py:1042-1046 derives the candidate from the key, never the value). -n is not on the denylist, so checkunsafeoptions passes. But transformkwarg('n', value, splitsinglecharoptions=True) (cmd.py:1600-1606) emits two argv tokens ['-n', '--upload-pack=<cmd']. git then parses the second token as --upload-pack and executes the attacker-supplied command. The guard never inspects the value that becomes a separate argv token. Impact…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r9mr-m37c-5fr3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-r9mr-m37c-5fr3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73625 Advisory: GitPython: Unsafe git option guard bypass via single-character kwarg value token smuggling enables arbitrary command execution IDs: CVE-2026-73625, GHSA-r9mr-m37c-5fr3 Record: https://patchnext.com/advisories/cve-2026-73625 (revision 3, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gitpython 3.1.54. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gitpython: affected <= 3.1.53; fixed in 3.1.54 ## Suggested inspection (read-only) - `python -m pip show gitpython`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gitpython. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r9mr-m37c-5fr3 (OSV record GHSA-r9mr-m37c-5fr3 lists affected ranges: PyPI gitpython >=0 <3.1.54 (fixed)) - Verified: https://github.com/advisories/GHSA-r9mr-m37c-5fr3 (GitHub-reviewed advisory GHSA-r9mr-m37c-5fr3 lists affected ranges: PyPI gitpython >=0 <=3.1.53) Commands are suggestions: review each one before running it.
Loading voting…