Skip to content

← Actionable
Medium, CVSS 5.3amended

Node.js Adapter for Hono: Unauthenticated memory-leak DoS via aborted WebSocket handshake

CVE-2026-73565GHSA-9mqv-5hh9-4cgg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hono/node-server 2.0.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-73565: 0.53% estimated exploitation activity in the next 30 days; percentile 44.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A WebSocket upgrade request to an upgradeWebSocket route with a missing or malformed Sec-WebSocket-Key header leaks memory permanently. The request's IncomingMessage is retained in an internal map and a pending promise is never settled, even though no connection is established. Since the route is reachable pre-handshake without authentication, an unauthenticated attacker can flood it to gradually exhaust memory. Details The built-in WebSocket helper cleans up its internal map only on a successful handshake or when the route guard rejects the request. When ws aborts the handshake because Sec-WebSocket-Key is missing or malformed, no connection event is emitted, so neither cleanup path runs and the entry is retained forever. A present-but-malformed key leaks identically, so a proxy that only checks for the header's presence does not mitigate it. Impact An unauthenticated attacker can flood any public upgradeWebSocket route with malformed-key upgrade requests, causing unbounded…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9mqv-5hh9-4cgg

  2. Revision 1 · created ·

    Published from osv record GHSA-9mqv-5hh9-4cgg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73565

Advisory: Node.js Adapter for Hono: Unauthenticated memory-leak DoS via aborted WebSocket handshake
IDs: CVE-2026-73565, GHSA-9mqv-5hh9-4cgg
Record: https://patchnext.com/advisories/cve-2026-73565 (revision 2, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @hono/node-server 2.0.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hono/node-server: affected >= 2.0.0, <= 2.0.9; fixed in 2.0.10

## Suggested inspection (read-only)
- `npm ls @hono/node-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hono/node-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9mqv-5hh9-4cgg (OSV record GHSA-9mqv-5hh9-4cgg lists affected ranges: npm @hono/node-server >=2.0.0 <2.0.10 (fixed))
- Verified: https://github.com/advisories/GHSA-9mqv-5hh9-4cgg (GitHub-reviewed advisory GHSA-9mqv-5hh9-4cgg lists affected ranges: npm @hono/node-server >=2.0.0 <=2.0.9)

Commands are suggestions: review each one before running it.

Loading voting…