@backstage/plugin-auth-backend: Unauthenticated OAuth account takeover via redirect_uri allowlist bypass
CVE-2026-73563GHSA-38hq-7x33-php4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-auth-backend 0.29.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/plugin-auth-backend
- Affected
- <= 0.29.1
- Fixed in
- 0.29.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-38hq-7x33-php4 lists affected ranges: npm @backstage/plugin-auth-backend >=0 <0.29.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-38hq-7x33-php4 lists affected ranges: npm @backstage/plugin-auth-backend >=0 <=0.29.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.7 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
- EPSS
- CVE-2026-73563: 0.17% estimated exploitation activity in the next 30 days; percentile 6.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The allowlist matching used by the experimental dynamic client registration and client ID metadata document (CIMD) features in @backstage/plugin-auth-backend matched glob patterns against the full URL string. A wildcard could therefore match across URL component boundaries: a pattern such as https://.example.com/callback, intended to allow subdomains of a trusted host, would also match an attacker-controlled URL such as https://attacker.example/x.example.com/callback. This applies to auth.experimentalDynamicClientRegistration.allowedRedirectUriPatterns as well as the allowedClientIdPatterns and allowedRedirectUriPatterns options of auth.experimentalClientIdMetadataDocuments. An attacker could use this to register an OAuth client whose redirect URI points to a host they control while still passing the allowlist, causing authorization codes to be delivered to the attacker when a victim completes an authorization flow. In addition, allowlist patterns without an explicit protocol…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-38hq-7x33-php4
- Revision 1 · created ·
Published from osv record GHSA-38hq-7x33-php4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73563 Advisory: @backstage/plugin-auth-backend: Unauthenticated OAuth account takeover via `redirect_uri` allowlist bypass IDs: CVE-2026-73563, GHSA-38hq-7x33-php4 Record: https://patchnext.com/advisories/cve-2026-73563 (revision 2, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-auth-backend 0.29.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/plugin-auth-backend: affected <= 0.29.1; fixed in 0.29.2 ## Suggested inspection (read-only) - `npm ls @backstage/plugin-auth-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/plugin-auth-backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-38hq-7x33-php4 (OSV record GHSA-38hq-7x33-php4 lists affected ranges: npm @backstage/plugin-auth-backend >=0 <0.29.2 (fixed)) - Verified: https://github.com/advisories/GHSA-38hq-7x33-php4 (GitHub-reviewed advisory GHSA-38hq-7x33-php4 lists affected ranges: npm @backstage/plugin-auth-backend >=0 <=0.29.1) Commands are suggestions: review each one before running it.
Loading voting…