Mongoose: Prototype pollution in mongoose update casting via __proto__-prefixed dotted path (Schema._getSchema/path getter)
CVE-2026-73562GHSA-664h-wqgq-64gw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mongoose 9.7.2, 8.24.1, 7.8.10, 6.13.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mongoose
- Affected
- < 6.13.10>= 7.0.0, < 7.8.10>= 8.0.0, < 8.24.1>= 9.0.0, < 9.7.2
- Fixed in
- 8.24.1, 7.8.10, 9.7.2, 6.13.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-664h-wqgq-64gw lists affected ranges: npm mongoose >=0 =7.0.0 =8.0.0 =9.0.0 <9.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-664h-wqgq-64gw lists affected ranges: npm mongoose >=0 =7.0.0 =8.0.0 =9.0.0 <9.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2026-73562: 0.50% estimated exploitation activity in the next 30 days; percentile 43.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? Prototype pollution in update casting: passing a user-controlled update to a Mongoose update, like MyModel.updateOne(filter, req.body), can cause Mongoose to set $fullPath and $parentSchemaDocArray on Object.prototype. Example: Patches Has the problem been patched? What versions should users upgrade to? 9.7.2, 8.24.1. 7.8.10, 6.13.10 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Check user-controlled updates for own proto properties before passing to Mongoose References Are there any links users can visit to find out more?
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-664h-wqgq-64gw
- Revision 1 · created ·
Published from osv record GHSA-664h-wqgq-64gw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73562 Advisory: Mongoose: Prototype pollution in mongoose update casting via __proto__-prefixed dotted path (Schema._getSchema/path getter) IDs: CVE-2026-73562, GHSA-664h-wqgq-64gw Record: https://patchnext.com/advisories/cve-2026-73562 (revision 2, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mongoose 9.7.2, 8.24.1, 7.8.10, 6.13.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mongoose: affected < 6.13.10; >= 7.0.0, < 7.8.10; >= 8.0.0, < 8.24.1; >= 9.0.0, < 9.7.2; fixed in 8.24.1, 7.8.10, 9.7.2, 6.13.10 ## Suggested inspection (read-only) - `npm ls mongoose --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mongoose. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-664h-wqgq-64gw (OSV record GHSA-664h-wqgq-64gw lists affected ranges: npm mongoose >=0 =7.0.0 =8.0.0 =9.0.0 <9.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-664h-wqgq-64gw (GitHub-reviewed advisory GHSA-664h-wqgq-64gw lists affected ranges: npm mongoose >=0 =7.0.0 =8.0.0 =9.0.0 <9.7.2) Commands are suggestions: review each one before running it.
Loading voting…