vLLM: SSRF + arbitrary local file read in MiMoV2OmniMultiModalProcessor _fetch_image and audio loader bypass MediaConnector protections
CVE-2026-73560GHSA-4hhp-h66f-j5j7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.26.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- < 0.26.0
- Fixed in
- 0.26.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4hhp-h66f-j5j7 lists affected ranges: PyPI vllm >=0 <0.26.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4hhp-h66f-j5j7 lists affected ranges: PyPI vllm >=0 <0.26.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-73560: 0.41% estimated exploitation activity in the next 30 days; percentile 35.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary vllm/transformersutils/processors/mimov2omni.py — the multimodal processor for MiMoV2OmniForCausalLM — issues requests.get(...) directly on user-supplied image and audio URL strings and Image.open(...) on user-supplied local paths, without the SSRF / allowedlocalmediapath checks that vllm.multimodal.utils.MediaConnector was hardened with in GHSA-qh4c-xf7m-gxfc, GHSA-v359-jj2v-j536, and GHSA-pf3h-qjgv-vcpr. This is the same bug class as those three published advisories, in a code path the patches missed. When a user passes a URL or local-file string through multimodaldata (e.g. LLM.generate(multimodaldata={"image": "http://..."})), the processor takes the unsanitized string and dispatches it without any URL-scheme allowlist, network-target allowlist, size cap, or local-path allowlist. Details File: vllm/transformersutils/processors/mimov2omni.py (current main) Sink 1 — image SSRF + local-file read (fetchimage, lines 231–249): Sink 2 — audio SSRF (around line 471):…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4hhp-h66f-j5j7
- Revision 2 · amended ·
Amended from osv record GHSA-4hhp-h66f-j5j7
- Revision 1 · created ·
Published from ghsa record GHSA-4hhp-h66f-j5j7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73560 Advisory: vLLM: SSRF + arbitrary local file read in MiMoV2OmniMultiModalProcessor `_fetch_image` and audio loader bypass MediaConnector protections IDs: CVE-2026-73560, GHSA-4hhp-h66f-j5j7 Record: https://patchnext.com/advisories/cve-2026-73560 (revision 3, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.26.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected < 0.26.0; fixed in 0.26.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4hhp-h66f-j5j7 (GitHub-reviewed advisory GHSA-4hhp-h66f-j5j7 lists affected ranges: PyPI vllm >=0 <0.26.0) - Verified: https://osv.dev/vulnerability/GHSA-4hhp-h66f-j5j7 (OSV record GHSA-4hhp-h66f-j5j7 lists affected ranges: PyPI vllm >=0 <0.26.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…