vLLM: Completion prompt lists fan out into unbounded engine requests
CVE-2026-73559GHSA-87x5-vmc3-756j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.26.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.19.0, < 0.26.0
- Fixed in
- 0.26.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-87x5-vmc3-756j lists affected ranges: PyPI vllm >=0.19.0 <0.26.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-73559: 0.58% estimated exploitation activity in the next 30 days; percentile 47.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The /v1/completions request model accepts prompt as a list of text prompts or a list of token-id prompts without any outer prompt-count bound. The serving path turns each element into a separate engine input, creates one engine generator per element, merges all generators, and allocates a response slot per prompt. An authenticated API client can therefore turn one request into an attacker-chosen number of backend subrequests before any aggregate request-count budget is enforced. Technical Details CompletionRequest.prompt allows both list-shaped prompt inputs and scalar prompts: The validator only requires some prompt-like input to be present: The renderer then expands list-shaped prompts as a sequence. prompttoseq() wraps a scalar string or a single token-id list, but returns a list[str] or list[list[int]] unchanged: OnlineRenderer.preprocesscompletion() appends that whole sequence, and the renderer processes every element: Finally, completion serving creates one backend…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-87x5-vmc3-756j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73559 Advisory: vLLM: Completion prompt lists fan out into unbounded engine requests IDs: CVE-2026-73559, GHSA-87x5-vmc3-756j Record: https://patchnext.com/advisories/cve-2026-73559 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.26.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.19.0, < 0.26.0; fixed in 0.26.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-87x5-vmc3-756j (GitHub-reviewed advisory GHSA-87x5-vmc3-756j lists affected ranges: PyPI vllm >=0.19.0 <0.26.0) Commands are suggestions: review each one before running it.
Loading voting…