Skip to content

← Actionable
Medium, CVSS 5.3amended

vLLM: Cross-User Data Leak Vulnerability

CVE-2026-73558GHSA-7m6h-x95x-82q5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.27.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    < 0.27.0
    Fixed in
    0.27.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-73558: 0.41% estimated exploitation activity in the next 30 days; percentile 35.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An integer overflow in the actandmulkernel kernel can cause the output of one user request to be incorporated into the response of another request within the same inference batch. Under certain conditions, the last request in a batch can receive a partial or complete copy of the first user's inference result, resulting in cross-user data leakage. Details The root cause is an integer overflow in the expression blockIdx.x 2 d at https://github.com/vllm-project/vllm/blob/ff712f6447093d07747c88680b9d006b119f5890/csrc/activationkernels.cu#L82. As a result, the computation for one user (User A) can incorrectly consume input data from another user (User B). In particular, when 2^32 is divisible by d, the overflow can cause User A's output to contain portions of User B's inference result. In some cases, User B's response may be copied entirely into User A's response. This constitutes a severe cross-user information disclosure vulnerability and is straightforward to trigger. PoC We…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7m6h-x95x-82q5

  2. Revision 2 · amended ·

    Amended from osv record GHSA-7m6h-x95x-82q5

  3. Revision 1 · created ·

    Published from ghsa record GHSA-7m6h-x95x-82q5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73558

Advisory: vLLM: Cross-User Data Leak Vulnerability
IDs: CVE-2026-73558, GHSA-7m6h-x95x-82q5
Record: https://patchnext.com/advisories/cve-2026-73558 (revision 3, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.27.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected < 0.27.0; fixed in 0.27.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7m6h-x95x-82q5 (GitHub-reviewed advisory GHSA-7m6h-x95x-82q5 lists affected ranges: PyPI vllm >=0 <0.27.0)
- Verified: https://osv.dev/vulnerability/GHSA-7m6h-x95x-82q5 (OSV record GHSA-7m6h-x95x-82q5 lists affected ranges: PyPI vllm >=0 <0.27.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…