Oh My Posh: Terminal escape sequence injection via unsanitized prompt segment data
CVE-2026-73506GHSA-fwjx-9p69-h25h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/jandedobbeleer/oh-my-posh 29.35.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/jandedobbeleer/oh-my-posh
- Affected
- <= 29.35.0
- Fixed in
- 29.35.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6111 lists affected ranges: Go github.com/jandedobbeleer/oh-my-posh >=0 <29.35.1+incompatible (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fwjx-9p69-h25h lists affected ranges: Go github.com/jandedobbeleer/oh-my-posh >=0 <=29.35.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- EPSS
- CVE-2026-73506: 0.18% estimated exploitation activity in the next 30 days; percentile 7.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Oh My Posh renders dynamic, potentially attacker-controlled strings (the current directory name, Git commit metadata, environment variable values, command output) into the prompt without neutralizing raw terminal control characters. An attacker who controls one of these values can inject ANSI/OSC escape sequences that the victim's terminal executes on every prompt render. (This is separate from the path-segment command-execution report; it has a different root cause and fix.) Details src/terminal/writer.go, write(s rune): the literal characters of rendered segment content are emitted to the output buffer, and the only neutralization is a lookup in formats.EscapeSequences, which per shell contains only the shell's prompt-length markers (\ for bash, % for zsh, nothing for fish/pwsh/cmd/nu). Raw C0/C1 control bytes (ESC 0x1b, BEL 0x07, CSI, OSC) are written verbatim. Oh My Posh's own styling is emitted through separate paths (writeEscapedAnsiString, writeColorise,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fwjx-9p69-h25h
- Revision 1 · created ·
Published from osv record GO-2026-6111
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73506 Advisory: Oh My Posh: Terminal escape sequence injection via unsanitized prompt segment data IDs: CVE-2026-73506, GHSA-fwjx-9p69-h25h Record: https://patchnext.com/advisories/cve-2026-73506 (revision 2, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/jandedobbeleer/oh-my-posh 29.35.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/jandedobbeleer/oh-my-posh: affected <= 29.35.0; fixed in 29.35.1 ## Suggested inspection (read-only) - Go github.com/jandedobbeleer/oh-my-posh: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/jandedobbeleer/oh-my-posh. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6111 (OSV record GO-2026-6111 lists affected ranges: Go github.com/jandedobbeleer/oh-my-posh >=0 <29.35.1+incompatible (fixed)) - Verified: https://github.com/advisories/GHSA-fwjx-9p69-h25h (GitHub-reviewed advisory GHSA-fwjx-9p69-h25h lists affected ranges: Go github.com/jandedobbeleer/oh-my-posh >=0 <=29.35.0) Commands are suggestions: review each one before running it.
Loading voting…