Skip to content

← Actionable
Medium, CVSS 5.3amended

kin-openapi openapi3filter: unauthenticated nil-pointer panic when validating a request against a content parameter whose media type has no schema

CVE-2026-73502GHSA-jpcw-4wr7-c3vq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/getkin/kin-openapi 0.144.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-73502: 0.51% estimated exploitation activity in the next 30 days; percentile 43.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

| Field | Value | |---|---| | Ecosystem | Go | | Package | github.com/getkin/kin-openapi | | Affected versions | <= 0.143.0 (introduced in v0.2.0, PR #90, 2019-05-07; reproduced on HEAD 30e2923) | | Patched versions | 0.144.0 | --- Summary openapi3filter.ValidateRequest contains a NULL-pointer-dereference denial of service: any unauthenticated client can crash the request-validation path with a single HTTP request. When an operation declares a content parameter (as opposed to a schema parameter) whose media type object has no schema, request validation dereferences that missing schema and panics. The document is legal under the OpenAPI Specification — kin-openapi's own doc.Validate() accepts it — and the defect affects both OpenAPI 3.0.x and 3.1.x. Depending on how the library is wired into the server (see Impact), this ranges from a per-request abort with unbounded panic-log growth to a full remote process crash. Details The decoder used for content parameters when no custom…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jpcw-4wr7-c3vq

  2. Revision 1 · created ·

    Published from osv record GO-2026-6112

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73502

Advisory: kin-openapi openapi3filter: unauthenticated nil-pointer panic when validating a request against a `content` parameter whose media type has no schema
IDs: CVE-2026-73502, GHSA-jpcw-4wr7-c3vq
Record: https://patchnext.com/advisories/cve-2026-73502 (revision 2, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/getkin/kin-openapi 0.144.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/getkin/kin-openapi: affected <= 0.143.0; fixed in 0.144.0

## Suggested inspection (read-only)
- Go github.com/getkin/kin-openapi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/getkin/kin-openapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6112 (OSV record GO-2026-6112 lists affected ranges: Go github.com/getkin/kin-openapi >=0 <0.144.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jpcw-4wr7-c3vq (GitHub-reviewed advisory GHSA-jpcw-4wr7-c3vq lists affected ranges: Go github.com/getkin/kin-openapi >=0 <=0.143.0)

Commands are suggestions: review each one before running it.

Loading voting…