Skip to content

← Actionable
High, CVSS 7.1amended

etcd: Watch API authorization bypass via open-ended range requests

CVE-2026-73499GHSA-xg4h-6gfc-h4m8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (go.etcd.io/etcd/v3 3.7.1, 3.6.14, 3.5.33; go.etcd.io/etcd/server/v3 3.7.1, 3.6.14, 3.5.33), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go go.etcd.io/etcd/v3

    Affected
    >= 3.7.0-alpha.0, < 3.7.1>= 3.6.0, < 3.6.14< 3.5.33
    Fixed in
    3.7.1, 3.5.33, 3.6.14
  • Go go.etcd.io/etcd/server/v3

    Affected
    < 3.5.33>= 3.6.0, < 3.6.14>= 3.7.0-alpha.0, < 3.7.1
    Fixed in
    3.5.33, 3.6.14, 3.7.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-73499: 0.66% estimated exploitation activity in the next 30 days; percentile 51.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? A user granted READ permission on a single, exact key can use the Watch gRPC API with clientv3.WithFromKey() (an open-ended, "from this key to the end of the keyspace" watch) to receive watch events for every key lexicographically greater than or equal to their permitted key — not just the one key they were granted. This is an authorization bypass in etcd's RBAC enforcement for the Watch API; Range/Get and DeleteRange requests are not affected. It only affects clusters with authentication enabled — clusters running without auth already allow unrestricted read access. Patches Has the problem been patched? What versions should users upgrade to? This vulnerability is patched in the following versions: - etcd 3.7.1 - etcd 3.6.14 - etcd 3.5.33 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? If upgrading is not immediately possible, the following mitigations reduce exposure: - Audit READ…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xg4h-6gfc-h4m8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GO-2026-6114

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73499

Advisory: etcd: Watch API authorization bypass via open-ended range requests
IDs: CVE-2026-73499, GHSA-xg4h-6gfc-h4m8
Record: https://patchnext.com/advisories/cve-2026-73499 (revision 3, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: go.etcd.io/etcd/v3 3.7.1, 3.6.14, 3.5.33; go.etcd.io/etcd/server/v3 3.7.1, 3.6.14, 3.5.33. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go go.etcd.io/etcd/v3: affected >= 3.7.0-alpha.0, < 3.7.1; >= 3.6.0, < 3.6.14; < 3.5.33; fixed in 3.7.1, 3.5.33, 3.6.14
- Go go.etcd.io/etcd/server/v3: affected < 3.5.33; >= 3.6.0, < 3.6.14; >= 3.7.0-alpha.0, < 3.7.1; fixed in 3.5.33, 3.6.14, 3.7.1

## Suggested inspection (read-only)
- Go go.etcd.io/etcd/v3: check the installed version with your package manager.
- Go go.etcd.io/etcd/server/v3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on go.etcd.io/etcd/v3, go.etcd.io/etcd/server/v3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6114 (OSV record GO-2026-6114 lists affected ranges: Go go.etcd.io/etcd/server/v3 >=0 =3.6.0 =3.7.0-alpha.0 <3.7.1 (fixed))
- Verified: https://github.com/advisories/GHSA-xg4h-6gfc-h4m8 (GitHub-reviewed advisory GHSA-xg4h-6gfc-h4m8 lists affected ranges: Go go.etcd.io/etcd/v3 >=3.7.0-alpha.0 =3.6.0 =0 <3.5.33)

Commands are suggestions: review each one before running it.

Loading voting…