Skip to content

← Actionable
High, CVSS 7.7amended

mcp-atlassian: Arbitrary file read via missing path validation in confluence_upload_attachment

CVE-2026-73498GHSA-g5r6-gv6m-f5jv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-atlassian 0.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-73498: 0.48% estimated exploitation activity in the next 30 days; percentile 41.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary confluenceuploadattachment passes filepath directly to open(filepath, "rb") with no path validation. Any authenticated MCP client — or an AI agent manipulated via prompt injection — can read any file the server process can access and exfiltrate it to Confluence as an attachment. Details Root cause: src/mcpatlassian/confluence/attachments.py, uploadattachmentdirect(): The fix already exists in the same file. downloadattachment() calls validatesafepath(targetpath). The developer's intent was to validate paths — upload was missed. Proven by the codebase itself. One-line fix — add before the open() call: PoC Stage 1 — Direct API (confirmed): Uploaded C:\Windows\System32\drivers\etc\hosts (826 bytes) → HTTP 200. Uploaded ~/.ssh/ided25519 (SSH private key) → HTTP 200. Stage 2 — End-to-end MCP client (confirmed against v0.21.1): Server opens file and uploads to Confluence without validation. Stage 3 — Prompt injection, no MCP credentials required (confirmed 2026-07-10): Payload…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g5r6-gv6m-f5jv

  2. Revision 1 · created ·

    Published from osv record GHSA-g5r6-gv6m-f5jv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73498

Advisory: mcp-atlassian: Arbitrary file read via missing path validation in confluence_upload_attachment
IDs: CVE-2026-73498, GHSA-g5r6-gv6m-f5jv
Record: https://patchnext.com/advisories/cve-2026-73498 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-atlassian 0.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp-atlassian: affected < 0.22.0; fixed in 0.22.0

## Suggested inspection (read-only)
- `python -m pip show mcp-atlassian`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-atlassian.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g5r6-gv6m-f5jv (OSV record GHSA-g5r6-gv6m-f5jv lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g5r6-gv6m-f5jv (GitHub-reviewed advisory GHSA-g5r6-gv6m-f5jv lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0)

Commands are suggestions: review each one before running it.

Loading voting…