blaze: Multiple HTTP/1.1 request-smuggling primitives in blaze's Java wire parser
CVE-2026-73494GHSA-mhvj-jhpq-885v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.http4s:blaze-http_3 1.0.0-M42, 0.23.18; org.http4s:blaze-http_2.13 1.0.0-M42, 0.23.18; org.http4s:http4s-blaze-server_2.13 0.23.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.http4s:blaze-http_3
- Affected
- <= 0.23.17>= 1.0.0-M1, <= 1.0.0-M41
- Fixed in
- 1.0.0-M42, 0.23.18
Maven org.http4s:blaze-http_2.13
- Affected
- <= 0.23.17>= 1.0.0-M1, <= 1.0.0-M41
- Fixed in
- 1.0.0-M42, 0.23.18
Maven org.http4s:http4s-blaze-server_2.13
- Affected
- <= 0.23.17
- Fixed in
- 0.23.18
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mhvj-jhpq-885v lists affected ranges: Maven org.http4s:http4s-blaze-server_2.13 >=0 =0 =1.0.0-M1 =0 =1.0.0-M1 <=1.0.0-M41
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-73494: 0.63% estimated exploitation activity in the next 30 days; percentile 50.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Five independent HTTP/1.1 conformance laxities in blaze's hand-written Java parser (http/src/main/java/org/http4s/blaze/http/parser/) cause request-boundary disagreement with a stricter intermediary. All are reachable from a default BlazeServerBuilder with no non-default configuration. Impact Actual exploitability depends on the fronting proxy — a boundary disagreement requires a pair of parsers that disagree. Where the proxy forwards the malformed bytes and derives a different message boundary, the consequences are the standard set: front-end ACL/auth bypass, response-queue poisoning on pooled backend connections, and cache poisoning. Risk concentrates on lenient or legacy intermediaries. Workarounds Deploy behind an RFC-strict reverse proxy (nginx, HAProxy, Envoy, ALB) that rejects or re-serializes malformed requests at the edge; this neutralizes most of these for deployments that cannot upgrade immediately.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mhvj-jhpq-885v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73494 Advisory: blaze: Multiple HTTP/1.1 request-smuggling primitives in blaze's Java wire parser IDs: CVE-2026-73494, GHSA-mhvj-jhpq-885v Record: https://patchnext.com/advisories/cve-2026-73494 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.http4s:blaze-http_3 1.0.0-M42, 0.23.18; org.http4s:blaze-http_2.13 1.0.0-M42, 0.23.18; org.http4s:http4s-blaze-server_2.13 0.23.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.http4s:blaze-http_3: affected <= 0.23.17; >= 1.0.0-M1, <= 1.0.0-M41; fixed in 1.0.0-M42, 0.23.18 - Maven org.http4s:blaze-http_2.13: affected <= 0.23.17; >= 1.0.0-M1, <= 1.0.0-M41; fixed in 1.0.0-M42, 0.23.18 - Maven org.http4s:http4s-blaze-server_2.13: affected <= 0.23.17; fixed in 0.23.18 ## Suggested inspection (read-only) - Maven org.http4s:blaze-http_3: check the installed version with your package manager. - Maven org.http4s:blaze-http_2.13: check the installed version with your package manager. - Maven org.http4s:http4s-blaze-server_2.13: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.http4s:blaze-http_3, org.http4s:blaze-http_2.13, org.http4s:http4s-blaze-server_2.13. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mhvj-jhpq-885v (GitHub-reviewed advisory GHSA-mhvj-jhpq-885v lists affected ranges: Maven org.http4s:http4s-blaze-server_2.13 >=0 =0 =1.0.0-M1 =0 =1.0.0-M1 <=1.0.0-M41) Commands are suggestions: review each one before running it.
Loading voting…