Skip to content

← Actionable
Medium, CVSS 4.3

Russh: Post-auth remote panic via pty-req with more than 130 terminal-mode records

CVE-2026-73489GHSA-cqjc-rmpq-xprq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (russh 0.62.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io russh

    Affected
    <= 0.62.3
    Fixed in
    0.62.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-73489: 0.45% estimated exploitation activity in the next 30 days; percentile 39.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A post-authentication denial-of-service panic in russh 0.62.2 (commit c4be19f1915c8682f4615c3fd50008512b474491, current default branch main as of 2026-07-22). An authenticated client sends a pty-req channel request carrying more than 130 terminal-mode records. The parser uses a fixed [(Pty::TTYOPEND, 0); 130] array but increments its counter i for every valid record (logging "too many pty codes" without returning), then slices &modes[0..i] — an out-of-bounds slice that panics (range end index 131 out of range for slice of length 130) before the application ptyrequest handler runs. This is reachable with the default server configuration and the default crypto config (curve25519-sha256 + chacha20-poly1305), requiring only an authenticated session channel — no caller-supplied parameter. It is reproduced end-to-end against the unmodified real russh 0.62.2 library (a real russh::client + russh::server over TCP, using the public Channel::requestpty(...) API); the PoC below links…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cqjc-rmpq-xprq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73489

Advisory: Russh: Post-auth remote panic via pty-req with more than 130 terminal-mode records
IDs: CVE-2026-73489, GHSA-cqjc-rmpq-xprq
Record: https://patchnext.com/advisories/cve-2026-73489 (revision 1, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: russh 0.62.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io russh: affected <= 0.62.3; fixed in 0.62.4

## Suggested inspection (read-only)
- crates.io russh: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on russh.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cqjc-rmpq-xprq (GitHub-reviewed advisory GHSA-cqjc-rmpq-xprq lists affected ranges: crates.io russh >=0 <=0.62.3)

Commands are suggestions: review each one before running it.

Loading voting…