Skip to content

← Actionable
Medium, CVSS 6.0amended

Flowise: IDOR vulnerability exists at the GET /api/v1/organization/customer-default-source endpoint

CVE-2026-73488GHSA-2364-jh4q-m9vm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    <= 3.1.2
    Fixed in
    3.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-73488: 0.37% estimated exploitation activity in the next 30 days; percentile 30.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An Insecure Direct Object Reference (IDOR) vulnerability exists at the GET /api/v1/organization/customer-default-source endpoint. This flaw allows an authenticated attacker to bypass authorization checks and retrieve sensitive payment and profile information of other customers by manipulating the customerId parameter. The exposed data includes email addresses, account balances, currency types, and internal billing configurations. Details The application fails to implement proper object-level access control. While the endpoint requires a valid session/token, it does not verify if the requesting user has the authority to access the specific customerId provided in the query string. When a request is made to: GET /api/v1/organization/customer-default-source?customerId=cusXXXX The server processes the request based solely on the existence of a valid session, returning the data associated with the ID regardless of the data owner's identity. Since customer IDs follow a predictable…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2364-jh4q-m9vm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2364-jh4q-m9vm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73488

Advisory: Flowise: IDOR vulnerability exists at the GET /api/v1/organization/customer-default-source endpoint
IDs: CVE-2026-73488, GHSA-2364-jh4q-m9vm
Record: https://patchnext.com/advisories/cve-2026-73488 (revision 3, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected <= 3.1.2; fixed in 3.1.3

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2364-jh4q-m9vm (OSV record GHSA-2364-jh4q-m9vm lists affected ranges: npm flowise >=0 <3.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-2364-jh4q-m9vm (GitHub-reviewed advisory GHSA-2364-jh4q-m9vm lists affected ranges: npm flowise >=0 <=3.1.2)

Commands are suggestions: review each one before running it.

Loading voting…