Russh: client wrong-length X25519 clone_from_slice panic (pre-auth DoS)
CVE-2026-73429GHSA-g9hv-x236-4qp3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (russh 0.62.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io russh
- Affected
- <= 0.62.3
- Fixed in
- 0.62.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g9hv-x236-4qp3 lists affected ranges: crates.io russh >=0 <=0.62.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-73429: 0.51% estimated exploitation activity in the next 30 days; percentile 43.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A malicious SSH server can crash a russh client session with a single malformed key-exchange reply, causing a pre-authentication Denial-of-Service before the server host key is verified. The embedding process itself stays up, but the connection is killed deterministically. Details Every other kex path in russh validates the peer ephemeral length before cloning: - Curve25519Kex::serverdh (russh/src/kex/curve25519.rs:61-65) checks if pubkeylen != 32 { return Err(crate::Error::Kex); } before clonefromslice. - The hybrid ML-KEM, ECDH-NIST, and DH/GEX paths all validate lengths. Only the client-side curve25519 computesharedsecret is missing the check. This asymmetric validation gap makes the bug easy to miss in code review: a malicious client cannot panic a russh server this way (the server path checks the length), but a malicious server can panic a russh client. Incriminated source code (repo-relative paths): - Vulnerable computesharedsecret: russh/src/kex/curve25519.rs:110-117…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g9hv-x236-4qp3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73429 Advisory: Russh: client wrong-length X25519 `clone_from_slice` panic (pre-auth DoS) IDs: CVE-2026-73429, GHSA-g9hv-x236-4qp3 Record: https://patchnext.com/advisories/cve-2026-73429 (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: russh 0.62.4. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io russh: affected <= 0.62.3; fixed in 0.62.4 ## Suggested inspection (read-only) - crates.io russh: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on russh. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g9hv-x236-4qp3 (GitHub-reviewed advisory GHSA-g9hv-x236-4qp3 lists affected ranges: crates.io russh >=0 <=0.62.3) Commands are suggestions: review each one before running it.
Loading voting…