Skip to content

← Actionable
Medium, CVSS 4.6amended

Trix: Stored XSS via HTMLParser attribute injection on paste

CVE-2026-73428GHSA-53g2-mvcc-q9x3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (action_text-trix 2.1.18; trix 2.1.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-73428: 0.35% estimated exploitation activity in the next 30 days; percentile 29.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Trix editor, in versions prior to 2.1.18, is vulnerable to XSS when crafted HTML is pasted into the editor. The HTMLParser processed a mock attachment, a <span carrying an empty data-trix-attachment="{}". The empty attachment object caused the element to bypass attachment handling, so its data-trix-attributes were applied to a plain string piece. The pre-2.1.18 StringPiece.fromJSON accepted the href without validation, so an attacker-supplied javascript: URI was carried into the document model and emitted verbatim into the serialized HTML, executing when the content was rendered and clicked. This is a stored XSS in any application that accepts untrusted rich text through Trix and renders the serialized output to other users. Applications that apply server-side HTML sanitization, such as the Rails built-in sanitizer, are additionally protected because the payload is neutralized on save. This vulnerability shares its fix with GHSA-53p3-c7vp-4mcc. Both are resolved by the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-53g2-mvcc-q9x3

  2. Revision 1 · created ·

    Published from osv record GHSA-53g2-mvcc-q9x3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73428

Advisory: Trix: Stored XSS via HTMLParser attribute injection on paste
IDs: CVE-2026-73428, GHSA-53g2-mvcc-q9x3
Record: https://patchnext.com/advisories/cve-2026-73428 (revision 2, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: action_text-trix 2.1.18; trix 2.1.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems action_text-trix: affected < 2.1.18; fixed in 2.1.18
- npm trix: affected < 2.1.18; fixed in 2.1.18

## Suggested inspection (read-only)
- RubyGems action_text-trix: check the installed version with your package manager.
- `npm ls trix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on action_text-trix, trix.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-53g2-mvcc-q9x3 (OSV record GHSA-53g2-mvcc-q9x3 lists affected ranges: npm trix >=0 =0 <2.1.18 (fixed))
- Verified: https://github.com/advisories/GHSA-53g2-mvcc-q9x3 (GitHub-reviewed advisory GHSA-53g2-mvcc-q9x3 lists affected ranges: npm trix >=0 =0 <2.1.18)

Commands are suggestions: review each one before running it.

Loading voting…