Skip to content

← Actionable
Low, CVSS 2.1amended

Trix is vulnerable to XSS through JSON deserialization bypass in drag-and-drop (Level0InputController)

CVE-2026-73427GHSA-53p3-c7vp-4mcc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (action_text-trix 2.1.18; trix 2.1.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-73427: 0.57% estimated exploitation activity in the next 30 days; percentile 47.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Trix editor, in versions prior to 2.1.18, is vulnerable to XSS when a crafted application/x-trix-document JSON payload is dropped into the editor in environments using the fallback Level0InputController (e.g., embedded WebViews lacking Input Events Level 2 support). The StringPiece.fromJSON method trusted href attributes from the JSON payload without sanitization. An attacker could craft a draggable element containing a javascript: URI in the href attribute that, when dropped into a vulnerable editor, would bypass DOMPurify sanitization and inject executable JavaScript into the DOM. Exploitation requires a specific environment (Level0InputController fallback) and social engineering (victim must drag and drop attacker-controlled content into the editor). Applications using server-side HTML sanitization (such as Rails' built-in sanitizer) are additionally protected, as the payload is neutralized on save. Patches Update Recommendation: Users should upgrade to Trix editor…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-53p3-c7vp-4mcc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-53p3-c7vp-4mcc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73427

Advisory: Trix is vulnerable to XSS through JSON deserialization bypass in drag-and-drop (Level0InputController)
IDs: CVE-2026-73427, GHSA-53p3-c7vp-4mcc
Record: https://patchnext.com/advisories/cve-2026-73427 (revision 3, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: action_text-trix 2.1.18; trix 2.1.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems action_text-trix: affected < 2.1.18; fixed in 2.1.18
- npm trix: affected < 2.1.18; fixed in 2.1.18

## Suggested inspection (read-only)
- RubyGems action_text-trix: check the installed version with your package manager.
- `npm ls trix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on action_text-trix, trix.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-53p3-c7vp-4mcc (OSV record GHSA-53p3-c7vp-4mcc lists affected ranges: npm trix >=0 =0 <2.1.18 (fixed))
- Verified: https://github.com/advisories/GHSA-53p3-c7vp-4mcc (GitHub-reviewed advisory GHSA-53p3-c7vp-4mcc lists affected ranges: npm trix >=0 =0 <2.1.18)

Commands are suggestions: review each one before running it.

Loading voting…