Trix has a Stored XSS vulnerability through serialized attributes
CVE-2026-73426GHSA-qmpg-8xg6-ph5q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (action_text-trix 2.1.17; trix 2.1.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems action_text-trix
- Affected
- < 2.1.17
- Fixed in
- 2.1.17
npm trix
- Affected
- < 2.1.17
- Fixed in
- 2.1.17
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qmpg-8xg6-ph5q lists affected ranges: RubyGems action_text-trix >=0 =0 <2.1.17 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qmpg-8xg6-ph5q lists affected ranges: RubyGems action_text-trix >=0 =0 <2.1.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-73426: 0.32% estimated exploitation activity in the next 30 days; percentile 25.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Trix editor, in versions prior to 2.1.17, is vulnerable to XSS attacks when a data-trix-serialized-attributes attribute bypasses the DOMPurify sanitizer. An attacker could craft HTML containing a data-trix-serialized-attributes attribute with a malicious payload that, when the content is rendered, could execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Patches Update Recommendation: Users should upgrade to Trix editor version 2.1.17 or later. References The XSS vulnerability was responsibly reported by Hackerone researcher newbiefromcoma.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qmpg-8xg6-ph5q
- Revision 1 · created ·
Published from osv record GHSA-qmpg-8xg6-ph5q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73426 Advisory: Trix has a Stored XSS vulnerability through serialized attributes IDs: CVE-2026-73426, GHSA-qmpg-8xg6-ph5q Record: https://patchnext.com/advisories/cve-2026-73426 (revision 2, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: action_text-trix 2.1.17; trix 2.1.17. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems action_text-trix: affected < 2.1.17; fixed in 2.1.17 - npm trix: affected < 2.1.17; fixed in 2.1.17 ## Suggested inspection (read-only) - RubyGems action_text-trix: check the installed version with your package manager. - `npm ls trix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on action_text-trix, trix. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qmpg-8xg6-ph5q (OSV record GHSA-qmpg-8xg6-ph5q lists affected ranges: RubyGems action_text-trix >=0 =0 <2.1.17 (fixed)) - Verified: https://github.com/advisories/GHSA-qmpg-8xg6-ph5q (GitHub-reviewed advisory GHSA-qmpg-8xg6-ph5q lists affected ranges: RubyGems action_text-trix >=0 =0 <2.1.17) Commands are suggestions: review each one before running it.
Loading voting…