Skip to content

← Actionable
Low, CVSS 3.7amended

@astrojs/netlify generates an overly-broad Netlify Image CDN allowlist because remotePatterns.pathname metacharacters are not escaped

CVE-2026-73425GHSA-hp3v-mfqw-h74c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@astrojs/netlify 8.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-73425: 0.27% estimated exploitation activity in the next 30 days; percentile 19.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The @astrojs/netlify adapter converts each image.remotePatterns entry into a regular expression that is written to .netlify/v1/config.json under images.remoteimages. Netlify's Image CDN uses these regexes as the allowlist that decides which remote image URLs it will optimize. remotePatternToRegex() escapes . in the hostname but interpolates the literal pathname into the regex without escaping regex metacharacters. As a result, the generated allowlist is broader than the pattern the developer declared, and broader than Astro's canonical matchPattern() helper (which compares non-wildcard pathnames by exact string equality). This is a residual of the same bug class addressed in CVE-2026-54300 (PR #17018, commit 1310277d). That fix corrected wildcard semantics and added a $ anchor but did not add metacharacter escaping for literal pathnames. Details In packages/integrations/netlify/src/index.ts, remotePatternToRegex() escapes dots in the hostname: but interpolates the pathname…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hp3v-mfqw-h74c

  2. Revision 1 · created ·

    Published from osv record GHSA-hp3v-mfqw-h74c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73425

Advisory: @astrojs/netlify generates an overly-broad Netlify Image CDN allowlist because remotePatterns.pathname metacharacters are not escaped
IDs: CVE-2026-73425, GHSA-hp3v-mfqw-h74c
Record: https://patchnext.com/advisories/cve-2026-73425 (revision 2, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @astrojs/netlify 8.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @astrojs/netlify: affected < 8.1.2; fixed in 8.1.2

## Suggested inspection (read-only)
- `npm ls @astrojs/netlify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @astrojs/netlify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hp3v-mfqw-h74c (OSV record GHSA-hp3v-mfqw-h74c lists affected ranges: npm @astrojs/netlify >=0 <8.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-hp3v-mfqw-h74c (GitHub-reviewed advisory GHSA-hp3v-mfqw-h74c lists affected ranges: npm @astrojs/netlify >=0 <8.1.2)

Commands are suggestions: review each one before running it.

Loading voting…