Auth.js: Configuration errors can cause existence-based auth checks to fail open (auth object populated with an error)
CVE-2026-73421GHSA-8fpg-xm3f-6cx3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next-auth 5.0.0-beta.32), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next-auth
- Affected
- >= 5.0.0-beta.0, <= 5.0.0-beta.31
- Fixed in
- 5.0.0-beta.32
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8fpg-xm3f-6cx3 lists affected ranges: npm next-auth >=5.0.0-beta.0 <=5.0.0-beta.31
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8fpg-xm3f-6cx3 lists affected ranges: npm next-auth >=5.0.0-beta.0 <5.0.0-beta.32 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-73421: 0.64% estimated exploitation activity in the next 30 days; percentile 50.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact next-auth (Auth.js) v5 applications that gate access by checking only for the existence of the auth object — the pattern shown in the official session management / protecting resources guide — are affected. When the Auth.js configuration produces a server-side error, the auth object exposed by the auth() wrapper (in middleware, Route Handlers, etc.) is populated with an error object instead of being null: Because this object is truthy, any authorization check of the form !!auth (or if (req.auth)) evaluates to true for every request, including unauthenticated ones. The application fails open: instead of denying access when the auth layer is broken, it grants access to everyone. A representative trigger is a provider that is missing required configuration. For example, a Keycloak provider with neither issuer nor authorization endpoint set logs: …and from that point on auth is the error object above, so !!auth is permanently true. The same fail-open behavior occurs for other…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-8fpg-xm3f-6cx3
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-8fpg-xm3f-6cx3
- Revision 1 · created ·
Published from ghsa record GHSA-8fpg-xm3f-6cx3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73421 Advisory: Auth.js: Configuration errors can cause existence-based auth checks to fail open (auth object populated with an error) IDs: CVE-2026-73421, GHSA-8fpg-xm3f-6cx3 Record: https://patchnext.com/advisories/cve-2026-73421 (revision 4, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next-auth 5.0.0-beta.32. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next-auth: affected >= 5.0.0-beta.0, <= 5.0.0-beta.31; fixed in 5.0.0-beta.32 ## Suggested inspection (read-only) - `npm ls next-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8fpg-xm3f-6cx3 (GitHub-reviewed advisory GHSA-8fpg-xm3f-6cx3 lists affected ranges: npm next-auth >=5.0.0-beta.0 <=5.0.0-beta.31) - Verified: https://osv.dev/vulnerability/GHSA-8fpg-xm3f-6cx3 (OSV record GHSA-8fpg-xm3f-6cx3 lists affected ranges: npm next-auth >=5.0.0-beta.0 <5.0.0-beta.32 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…