Skip to content

← Actionable
Critical, CVSS 9.1amended

Auth.js: Email normalizer validates the address before Unicode normalization, allowing a homoglyph @ bypass

CVE-2026-73420GHSA-7rqj-j65f-68wh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@auth/core 0.41.3; next-auth 5.0.0-beta.32, 4.24.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @auth/core

    Affected
    >= 0.1.0, < 0.41.3
    Fixed in
    0.41.3
  • npm next-auth

    Affected
    >= 4.10.3, < 4.24.15>= 5.0.0-beta.1, <= 5.0.0-beta.31
    Fixed in
    5.0.0-beta.32, 4.24.15

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-73420: 0.73% estimated exploitation activity in the next 30 days; percentile 54.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The default email-address normalizer used by the email/magic-link sign-in flow validates the address before applying Unicode normalization. An address can contain a Unicode character that is not an ASCII @ (U+0040) but canonicalizes to one under NFKC/NFKD normalization (the normalization commonly applied by mail libraries and services for internationalized email). Such an address passes the normalizer's single-@ check, but a downstream mail library that normalizes the string then sees two @ separators and may deliver the passwordless sign-in link to a different recipient than intended. This is an instance of validating before canonicalizing. Am I affected? You may be affected if all of the following hold: - You use next-auth = 4.0.0, < 4.24.14, or @auth/core = 0.1.0, < 0.41.3. - You have the email / magic-link (passwordless) provider enabled. - You rely on the built-in default identifier normalizer (you have not supplied your own normalizeIdentifier). - Your…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-7rqj-j65f-68wh

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-7rqj-j65f-68wh

  4. Revision 1 · created ·

    Published from ghsa record GHSA-7rqj-j65f-68wh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73420

Advisory: Auth.js: Email normalizer validates the address before Unicode normalization, allowing a homoglyph @ bypass
IDs: CVE-2026-73420, GHSA-7rqj-j65f-68wh
Record: https://patchnext.com/advisories/cve-2026-73420 (revision 4, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @auth/core 0.41.3; next-auth 5.0.0-beta.32, 4.24.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @auth/core: affected >= 0.1.0, < 0.41.3; fixed in 0.41.3
- npm next-auth: affected >= 4.10.3, < 4.24.15; >= 5.0.0-beta.1, <= 5.0.0-beta.31; fixed in 5.0.0-beta.32, 4.24.15

## Suggested inspection (read-only)
- `npm ls @auth/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls next-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @auth/core, next-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7rqj-j65f-68wh (GitHub-reviewed advisory GHSA-7rqj-j65f-68wh lists affected ranges: npm @auth/core >=0.1.0 =4.10.3 =5.0.0-beta.1 <=5.0.0-beta.31)
- Verified: https://osv.dev/vulnerability/GHSA-7rqj-j65f-68wh (OSV record GHSA-7rqj-j65f-68wh lists affected ranges: npm @auth/core >=0.1.0 =4.10.3 =5.0.0-beta.1 <5.0.0-beta.32 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…