Auth.js: OAuth state, nonce, and PKCE check cookies are not bound to the provider that created them
CVE-2026-73419GHSA-x445-f3h2-j279
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@auth/core 0.41.3; next-auth 5.0.0-beta.32, 4.24.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @auth/core
- Affected
- <= 0.41.2
- Fixed in
- 0.41.3
npm next-auth
- Affected
- >= 5.0.0-beta.1, <= 5.0.0-beta.31<= 4.24.14
- Fixed in
- 5.0.0-beta.32, 4.24.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x445-f3h2-j279 lists affected ranges: npm @auth/core >=0 =5.0.0-beta.1 =0 <4.24.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x445-f3h2-j279 lists affected ranges: npm @auth/core >=0 =5.0.0-beta.1 =0 <=4.24.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-73419: 0.25% estimated exploitation activity in the next 30 days; percentile 16.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Auth.js stores the OAuth/OIDC anti-CSRF checks (state, nonce, and the PKCE verifier) in global cookies that are not bound to the provider that created them. On callback, a check value minted during a sign-in started with one provider can satisfy the callback for a different provider, because the stored cookie is not verified against the callback provider's identity (provider id, issuer, client id, or redirect URI). In a multi-provider app that allows account linking while logged in, this provider-confusion / mix-up condition can let an attacker link their account at a second provider to a victim's user. Am I affected? You may be affected if all of the following hold: - You use next-auth <= 4.24.14 or = 5.0.0-beta.1, <= 5.0.0-beta.31, or @auth/core <= 0.41.2. - You configure multiple OAuth/OIDC providers. - You allow users to link additional providers while logged in. - At least one configured provider's authorization request is observable by an attacker, and at least one…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x445-f3h2-j279
- Revision 1 · created ·
Published from osv record GHSA-x445-f3h2-j279
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73419 Advisory: Auth.js: OAuth state, nonce, and PKCE check cookies are not bound to the provider that created them IDs: CVE-2026-73419, GHSA-x445-f3h2-j279 Record: https://patchnext.com/advisories/cve-2026-73419 (revision 2, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @auth/core 0.41.3; next-auth 5.0.0-beta.32, 4.24.15. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @auth/core: affected <= 0.41.2; fixed in 0.41.3 - npm next-auth: affected >= 5.0.0-beta.1, <= 5.0.0-beta.31; <= 4.24.14; fixed in 5.0.0-beta.32, 4.24.15 ## Suggested inspection (read-only) - `npm ls @auth/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls next-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @auth/core, next-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x445-f3h2-j279 (OSV record GHSA-x445-f3h2-j279 lists affected ranges: npm @auth/core >=0 =5.0.0-beta.1 =0 <4.24.15 (fixed)) - Verified: https://github.com/advisories/GHSA-x445-f3h2-j279 (GitHub-reviewed advisory GHSA-x445-f3h2-j279 lists affected ranges: npm @auth/core >=0 =5.0.0-beta.1 =0 <=4.24.14) Commands are suggestions: review each one before running it.
Loading voting…