Auth.js: getToken() throws an uncaught exception on malformed Bearer authorization headers
CVE-2026-73418GHSA-xmf8-cvqr-rfgj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@auth/core 0.41.3; next-auth 5.0.0-beta.32, 4.24.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @auth/core
- Affected
- >= 0.1.0, < 0.41.3
- Fixed in
- 0.41.3
npm next-auth
- Affected
- >= 5.0.0-beta.0, <= 5.0.0-beta.31>= 4.0.6, <= 4.24.14
- Fixed in
- 5.0.0-beta.32, 4.24.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xmf8-cvqr-rfgj lists affected ranges: npm @auth/core >=0.1.0 =5.0.0-beta.0 =4.0.6 <4.24.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xmf8-cvqr-rfgj lists affected ranges: npm @auth/core >=0.1.0 =5.0.0-beta.0 =4.0.6 <=4.24.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-73418: 0.88% estimated exploitation activity in the next 30 days; percentile 59.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The exported getToken() helper (next-auth/jwt and @auth/core/jwt) can throw an uncaught exception when it reads a malformed Authorization: Bearer … header. When no session cookie is present, getToken() URL-decodes the bearer value before validating it, and malformed percent-encoding causes the decode step to throw rather than being treated as an invalid token. Because getToken() is commonly called in API routes, middleware, and other request handlers, a single unauthenticated request can trigger an unhandled exception in code paths that authenticate requests. Am I affected? You are affected if all of the following hold: - You use next-auth <= 5.0.0-beta.25 (or @auth/core exposing the same getToken() implementation). - Your application calls getToken() directly — for example in a Route Handler, middleware, or server-side request handler. - You do not wrap that getToken() call in your own try/catch. You are not affected if you only use the framework's auth() helper and never…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xmf8-cvqr-rfgj
- Revision 1 · created ·
Published from osv record GHSA-xmf8-cvqr-rfgj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73418 Advisory: Auth.js: getToken() throws an uncaught exception on malformed Bearer authorization headers IDs: CVE-2026-73418, GHSA-xmf8-cvqr-rfgj Record: https://patchnext.com/advisories/cve-2026-73418 (revision 2, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @auth/core 0.41.3; next-auth 5.0.0-beta.32, 4.24.15. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @auth/core: affected >= 0.1.0, < 0.41.3; fixed in 0.41.3 - npm next-auth: affected >= 5.0.0-beta.0, <= 5.0.0-beta.31; >= 4.0.6, <= 4.24.14; fixed in 5.0.0-beta.32, 4.24.15 ## Suggested inspection (read-only) - `npm ls @auth/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls next-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @auth/core, next-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xmf8-cvqr-rfgj (OSV record GHSA-xmf8-cvqr-rfgj lists affected ranges: npm @auth/core >=0.1.0 =5.0.0-beta.0 =4.0.6 <4.24.15 (fixed)) - Verified: https://github.com/advisories/GHSA-xmf8-cvqr-rfgj (GitHub-reviewed advisory GHSA-xmf8-cvqr-rfgj lists affected ranges: npm @auth/core >=0.1.0 =5.0.0-beta.0 =4.0.6 <=4.24.14) Commands are suggestions: review each one before running it.
Loading voting…