Skip to content

← Actionable
High, CVSS 8.6amended

JupyterLab: Cross-site scripting (XSS) via crafted settings file (overrides.json)

CVE-2026-73417GHSA-pppj-hq3g-57pj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlab 4.6.2, 4.5.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI jupyterlab

    Affected
    >= 4.6.0, <= 4.6.1>= 3.3.0, <= 4.5.9
    Fixed in
    4.6.2, 4.5.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:L · score source
EPSS
  • CVE-2026-73417: 0.75% estimated exploitation activity in the next 30 days; percentile 54.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

JupyterLab 4.5+ allows notebook settings to be shared and applied through an overrides.json file using the Import button in the Settings Editor. Certain notebook display settings were not properly validated before being applied. As a result, a crafted settings file could contain hidden instructions that run as code inside JupyterLab when imported, instead of only changing a display preference. Because importing a settings file appears harmless, a user could import a file shared by another party without realizing it could do more. On multi-tenant file systems without proper permission control, another user could plant a malicious overrides.json. CVE assignment pending, GitHub CNA is experiencing severe backlog Impact When a malicious settings file is applied, the embedded code runs with the same access as the affected user. This could allow an attacker to read or modify that user's notebooks and files, and to run code on the user's behalf through the notebook server, including on any…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-pppj-hq3g-57pj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-pppj-hq3g-57pj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73417

Advisory: JupyterLab: Cross-site scripting (XSS) via crafted settings file (`overrides.json`)
IDs: CVE-2026-73417, GHSA-pppj-hq3g-57pj
Record: https://patchnext.com/advisories/cve-2026-73417 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyterlab 4.6.2, 4.5.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyterlab: affected >= 4.6.0, <= 4.6.1; >= 3.3.0, <= 4.5.9; fixed in 4.6.2, 4.5.10

## Suggested inspection (read-only)
- `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyterlab.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pppj-hq3g-57pj (OSV record GHSA-pppj-hq3g-57pj lists affected ranges: PyPI jupyterlab >=4.6.0 =3.3.0 <4.5.10 (fixed))
- Verified: https://github.com/advisories/GHSA-pppj-hq3g-57pj (GitHub-reviewed advisory GHSA-pppj-hq3g-57pj lists affected ranges: PyPI jupyterlab >=4.6.0 =3.3.0 <=4.5.9)

Commands are suggestions: review each one before running it.

Loading voting…