Shescape: Path disclosure on Unix with Zsh
CVE-2026-73412GHSA-6v4m-fw66-8r4x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shescape 3.0.1, 2.1.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm shescape
- Affected
- < 2.1.14>= 3.0.0, < 3.0.1
- Fixed in
- 3.0.1, 2.1.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6v4m-fw66-8r4x lists affected ranges: npm shescape >=0 =3.0.0 <3.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6v4m-fw66-8r4x lists affected ranges: npm shescape >=0 =3.0.0 <3.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-73412: 0.61% estimated exploitation activity in the next 30 days; percentile 49.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This impacts users of Shescape on Unix systems that explicitly configure shell to Zsh, or true when the default shell is Zsh, using the escape and escapeAll. The Zsh options EXTENDEDGLOB and MAGICEQUALSUBST exacerbate the problem. In certain case, an attacker can leverage home directory expansion and extended glob syntax to obtain lists of files and directories on the system. Depending on what the command does, this may be used to leak more information. Without option / with MAGICEQUALSUBST With EXTENDEDGLOB Patches This bug has been patched in [v2.1.14] and [v3.0.1] which you can upgrade to now. If you are already using v3 of Shescape, no further changes are required. If you are using v2 of Shescape it is recommended to upgrade as this version reaches end-of-life status on 2026-09-28, follow the [migration guide] to upgrade to v3. No patches will be released for version of Shescape lower than v2.0.0. Workarounds Alternatively, users of Shescape can 1) refrain from using Zsh,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6v4m-fw66-8r4x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6v4m-fw66-8r4x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73412 Advisory: Shescape: Path disclosure on Unix with Zsh IDs: CVE-2026-73412, GHSA-6v4m-fw66-8r4x Record: https://patchnext.com/advisories/cve-2026-73412 (revision 3, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shescape 3.0.1, 2.1.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm shescape: affected < 2.1.14; >= 3.0.0, < 3.0.1; fixed in 3.0.1, 2.1.14 ## Suggested inspection (read-only) - `npm ls shescape --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shescape. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6v4m-fw66-8r4x (OSV record GHSA-6v4m-fw66-8r4x lists affected ranges: npm shescape >=0 =3.0.0 <3.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-6v4m-fw66-8r4x (GitHub-reviewed advisory GHSA-6v4m-fw66-8r4x lists affected ranges: npm shescape >=0 =3.0.0 <3.0.1) Commands are suggestions: review each one before running it.
Loading voting…