Skip to content

← Actionable
Medium, CVSS 4.9amended

Budibase: SSO OAuth2 Token Leakage via User Metadata Endpoints to Power-Role Users

CVE-2026-73304GHSA-fcrw-f7gg-6g9f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.39.25), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-73304: 0.48% estimated exploitation activity in the next 30 days; percentile 41.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The /api/users/metadata and /api/users/metadata/:id endpoints in @budibase/server return full global user profiles to any user with POWER role or above. For SSO-authenticated users (OIDC, Google), the response includes oauth2.accessToken and oauth2.refreshToken fields, leaking identity provider credentials to other users who should not have access to them. Details When a user authenticates via SSO (OIDC or Google), the OAuth2 tokens are stored in the global CouchDB user document at packages/backend-core/src/auth/auth.ts:170-173: The user metadata endpoints are protected by PermissionType.USER, PermissionLevel.READ (packages/server/src/api/routes/user.ts:11), which maps to the POWER permission set (packages/backend-core/src/security/permissions.ts:99). Path 1 — List all users (GET /api/users/metadata): 1. controller.fetchMetadata → sdk.users.fetchMetadata() (packages/server/src/sdk/users/utils.ts:78) 2. → getGlobalUsers() → getRawGlobalUsers()…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fcrw-f7gg-6g9f

  2. Revision 1 · created ·

    Published from osv record GHSA-fcrw-f7gg-6g9f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73304

Advisory: Budibase: SSO OAuth2 Token Leakage via User Metadata Endpoints to Power-Role Users
IDs: CVE-2026-73304, GHSA-fcrw-f7gg-6g9f
Record: https://patchnext.com/advisories/cve-2026-73304 (revision 2, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.39.25. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @budibase/server: affected < 3.39.25; fixed in 3.39.25

## Suggested inspection (read-only)
- `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @budibase/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fcrw-f7gg-6g9f (OSV record GHSA-fcrw-f7gg-6g9f lists affected ranges: npm @budibase/server >=0 <3.39.25 (fixed))
- Verified: https://github.com/advisories/GHSA-fcrw-f7gg-6g9f (GitHub-reviewed advisory GHSA-fcrw-f7gg-6g9f lists affected ranges: npm @budibase/server >=0 <3.39.25)

Commands are suggestions: review each one before running it.

Loading voting…