Skip to content

← Actionable
High, CVSS 7.6amended

Semaphore UI: CSRF vulnerability on password change endpoint - No CSRF token or password confirmation

CVE-2026-73292GHSA-8cj9-r88m-8945

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/semaphoreui/semaphore 0.0.0-20260707190631-c59c3dc9035b), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-73292: 0.23% estimated exploitation activity in the next 30 days; percentile 14.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The password change form is vulnerable to CSRF, allowing an attacker to change a user password (even the administrator) by tricking a connected user to visit a malicious website. The vulnerability has been tested with version 2.18.20. Details The password change endpoint of Semaphore UI does not implement any CSRF protection: - No CSRF token required - No current password confirmation required - Authentication relies solely on a session cookie (semaphore) with no SameSite enforcement A malicious page can silently change the password of any authenticated user who visits it by submitting the /api/users/<id/password forms. PoC To reproduce the exploit, you can use the following python script: Example : 1 - Run the previous script with the url of the targeted semaphore instance and the id of the targeted user. The script will serve a malicious webpage on port 1337. 2 - Connect to semaphore UI in another tab with the targeted user. 3 - In the same browser, visit the malicious…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8cj9-r88m-8945

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6370

  3. Revision 1 · created ·

    Published from osv record GHSA-8cj9-r88m-8945

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73292

Advisory: Semaphore UI: CSRF vulnerability on password change endpoint - No CSRF token or password confirmation
IDs: CVE-2026-73292, GHSA-8cj9-r88m-8945
Record: https://patchnext.com/advisories/cve-2026-73292 (revision 3, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/semaphoreui/semaphore 0.0.0-20260707190631-c59c3dc9035b. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/semaphoreui/semaphore: affected < 0.0.0-20260707190631-c59c3dc9035b; fixed in 0.0.0-20260707190631-c59c3dc9035b

## Suggested inspection (read-only)
- Go github.com/semaphoreui/semaphore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/semaphoreui/semaphore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8cj9-r88m-8945 (OSV record GHSA-8cj9-r88m-8945 lists affected ranges: Go github.com/semaphoreui/semaphore >=0 <0.0.0-20260707190631-c59c3dc9035b (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6370 (OSV record GO-2026-6370 lists affected ranges: Go github.com/semaphoreui/semaphore >=0 <0.0.0-20260707190631-c59c3dc9035b (fixed))
- Verified: https://github.com/advisories/GHSA-8cj9-r88m-8945 (GitHub-reviewed advisory GHSA-8cj9-r88m-8945 lists affected ranges: Go github.com/semaphoreui/semaphore >=0 <0.0.0-20260707190631-c59c3dc9035b)

Commands are suggestions: review each one before running it.

Loading voting…