Skip to content

← Actionable
Medium, CVSS 5.4amended

Prowler: Stored XSS in HTML reports through unescaped cloud resource tags

CVE-2026-73262GHSA-c2jg-2778-ggm4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (prowler-cloud 5.37.0; prowler 5.37.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-73262: 0.30% estimated exploitation activity in the next 30 days; percentile 22.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Prowler's HTML output formatter inserts finding.resourcetags into the generated report without HTML escaping. A cloud principal who can create or edit a resource tag in an account that is later scanned can store HTML or JavaScript in that tag. When another user opens the generated Prowler HTML report, the payload executes in the report page. Impact This is stored cross-site scripting in a security report artifact. The attacker needs permission to influence tags on a scanned cloud resource, and the victim must open the generated HTML report. In that context, JavaScript can read and modify the report DOM, alter displayed findings, and interact with any same-origin local or hosted report content available to the browser. This can undermine trust in generated security findings and can expose data contained in the report page. Gate checks The repository has 13,875 GitHub stars, which is above the 10,000 star floor. SECURITY.md is present and does not reject GitHub private…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c2jg-2778-ggm4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-c2jg-2778-ggm4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-c2jg-2778-ggm4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73262

Advisory: Prowler: Stored XSS in HTML reports through unescaped cloud resource tags
IDs: CVE-2026-73262, GHSA-c2jg-2778-ggm4
Record: https://patchnext.com/advisories/cve-2026-73262 (revision 3, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: prowler-cloud 5.37.0; prowler 5.37.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI prowler-cloud: affected <= 5.36.0; fixed in 5.37.0
- PyPI prowler: affected <= 5.36.0; fixed in 5.37.0

## Suggested inspection (read-only)
- `python -m pip show prowler-cloud`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show prowler`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on prowler-cloud, prowler.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c2jg-2778-ggm4 (GitHub-reviewed advisory GHSA-c2jg-2778-ggm4 lists affected ranges: PyPI prowler >=0 =0 <=5.36.0)
- Verified: https://osv.dev/vulnerability/GHSA-c2jg-2778-ggm4 (OSV record GHSA-c2jg-2778-ggm4 lists affected ranges: PyPI prowler >=0 =0 <5.37.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…